summaryrefslogtreecommitdiff
path: root/gui-libs/gtk-layer-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 11:50:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 11:50:23 +0100
commita2844b413d00a2859401e017a0311986151e1594 (patch)
tree3758da107fb05d4012a3f4813be2bf13c03d3985 /gui-libs/gtk-layer-shell
parent1ac83daac7198a5717483e1cfab669ba4f12debe (diff)
gentoo auto-resync : 16:04:2023 - 11:50:23
Diffstat (limited to 'gui-libs/gtk-layer-shell')
-rw-r--r--gui-libs/gtk-layer-shell/Manifest2
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index 9a8964a11c01..866c12fe3122 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1,3 +1,5 @@
DIST gtk-layer-shell-0.8.0.tar.gz 134857 BLAKE2B 2f41411c849182f95c068040a17e961a34d1a3df0bb1280b6c57046729396108d4627b5cf9bd826f17ffb5cf77f6761212af159d4326b2d34d9663063667f9f4 SHA512 710019b05785abc3cc8bc639a110f141dd2f37ce1d78e03ed361f1c21caee6c43817499fa05c8228f233bff3ac0b6f6123fa9014a87ae99edb6b10e4ff8f3dde
+DIST gtk-layer-shell-0.8.1.tar.gz 136156 BLAKE2B 19c16d49d119572b0a3ef9bf0aee2341dedb4b2e5afedee16b9817e16fcd2adba7696a9d6f2f01b4ebaa3636c116d8977079a9b83ed1941f9d97df9389425780 SHA512 070673a73166c9fd0ea10e6aa98c480318fbf8a6c2dff2a9b4900aea40bb59680d41d9bba9917953fabe4358c0dfa6c3d0221c579ada37cee72ce23433b40329
EBUILD gtk-layer-shell-0.8.0.ebuild 1331 BLAKE2B ca431ce8665b4305ae40d26ee4f4ed94e6a058d69669f18b07284d3540544703e6dbe54e800570e0cd6105a523b4882b4c3538882070418c46b9b6d2fac5a02e SHA512 efb2fa0d1ace8003e59cac02b9a20ec8e46ce53d03d8c83447f457cf1a0e6bc0e1f540d8d912125bcd78a146bdb643d7525b85f431b60d24b8855c79844e38a9
+EBUILD gtk-layer-shell-0.8.1.ebuild 1334 BLAKE2B 3f85f2836823f08ec2bf5a885828f7056a69991cfa1c9046864ae5201f77c9db5cbfe764394d3e6d17809290f01debdbe9bc56f35479e5b42cd2498202ee7865 SHA512 ee269a9f18d50098e788c33c8b3623d5b38e39205203d90d5976a72f6db31494aa673dc79cdee63f72215d8ddf4a031998e256250959f7886ff6be9868b84d0f
MISC metadata.xml 495 BLAKE2B 59bee54b6a6cc173655e2b482873f3ec5a21854a7dfcde8f6073a3c003642802978b182db94dae86c82c0b2409a153691b83720471530e4435ce0eebc5833f19 SHA512 625076c53f3dafb1812000eb3d50a68a837d751e53697429fabc6369161056f8ec16db584e830848cf57b659a10b8ece4b2cddeff1402ab42c4ff474aa954261
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild
new file mode 100644
index 000000000000..b62f502a1ad6
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+VALA_USE_DEPEND="vapigen"
+inherit vala meson python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising LGPL-3+"
+SLOT="0"
+IUSE="examples gtk-doc introspection test vala"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.24.37:3[introspection?,wayland]
+ >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-protocols-1.16
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( ${PYTHON_DEPS} )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ $(meson_use test tests)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}