summaryrefslogtreecommitdiff
path: root/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild')
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
index 8642e22e21e1..f0ce88fcabfe 100644
--- a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
@@ -22,21 +22,21 @@ IUSE="elogind systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
- >=media-video/pipewire-0.3.2:=
+ >=media-video/pipewire-0.3.34:=
+ dev-libs/inih
dev-libs/wayland
- >=dev-libs/wayland-protocols-1.14:=
- elogind? ( >=sys-auth/elogind-237 )
- systemd? ( >=sys-apps/systemd-237 )
+ || (
+ systemd? ( >=sys-apps/systemd-237 )
+ elogind? ( >=sys-auth/elogind-237 )
+ sys-libs/basu
+ )
"
RDEPEND="
${DEPEND}
sys-apps/xdg-desktop-portal
"
BDEPEND="
- >=media-video/pipewire-0.3.2:=
- >=dev-libs/wayland-protocols-1.14
- >=dev-util/meson-0.50.0
- dev-libs/inih:0
+ dev-libs/wayland-protocols
virtual/pkgconfig
"
@@ -44,5 +44,12 @@ src_configure() {
local emesonargs=(
"-Dwerror=false"
)
+ if use systemd; then
+ emesonargs+=(-Dsd-bus-provider=libsystemd)
+ elif use elogind; then
+ emesonargs+=(-Dsd-bus-provider=libelogind)
+ else
+ emesonargs+=(-Dsd-bus-provider=basu)
+ fi
meson_src_configure
}