summaryrefslogtreecommitdiff
path: root/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild')
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
new file mode 100644
index 000000000000..ee6f4d833661
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="xdg-desktop-portal backend for wlroots"
+HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ #KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS=""
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.2.9:=
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14:=
+ elogind? ( >=sys-auth/elogind-237 )
+ systemd? ( >=sys-apps/systemd-237 )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=media-video/pipewire-0.2.9:=
+ >=dev-libs/wayland-protocols-1.14
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-DHAVE_SYSTEMD=1")
+ else
+ emesonargs+=("-DHAVE_ELOGIND=1")
+ fi
+
+ meson_src_configure
+}