summaryrefslogtreecommitdiff
path: root/gui-wm/hyprland/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-08 03:26:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-08 03:26:28 +0100
commit6cefebc8e850c862f7623af22feef1b895a79884 (patch)
tree660a20a0730b33917d3767dea68a44fb142ccea8 /gui-wm/hyprland/files
parentcd25c8de05c7dc4ab208846c70ef68ab015f9342 (diff)
gentoo auto-resync : 08:08:2023 - 03:26:28
Diffstat (limited to 'gui-wm/hyprland/files')
-rw-r--r--gui-wm/hyprland/files/hyprland-0.28.0-no-wlroots-automagic-r1.patch20
-rw-r--r--gui-wm/hyprland/files/hyprland-0.28.0-no-wlroots-automagic.patch14
2 files changed, 20 insertions, 14 deletions
diff --git a/gui-wm/hyprland/files/hyprland-0.28.0-no-wlroots-automagic-r1.patch b/gui-wm/hyprland/files/hyprland-0.28.0-no-wlroots-automagic-r1.patch
new file mode 100644
index 000000000000..ca37e4e7c16d
--- /dev/null
+++ b/gui-wm/hyprland/files/hyprland-0.28.0-no-wlroots-automagic-r1.patch
@@ -0,0 +1,20 @@
+# Disable automagic, otherwise wlroots will enable features if dependencies are present.
+# Enable x11-backend only if xwayland is enabled.
+diff --git a/meson.build b/meson.build
+index 6a94dee6..08993f8a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -39,7 +39,12 @@ add_project_arguments(
+ ],
+ language: 'cpp')
+
+-wlroots = subproject('wlroots', default_options: ['examples=false'])
++if get_option('xwayland').enabled()
++ wlroots = subproject('wlroots', default_options: ['backends=drm,libinput,x11','examples=false','renderers=gles2','xcb-errors=disabled','xwayland=enabled'])
++else
++ wlroots = subproject('wlroots', default_options: ['backends=drm,libinput','examples=false','renderers=gles2','xcb-errors=disabled','xwayland=disabled'])
++endif
++
+ have_xwlr = wlroots.get_variable('features').get('xwayland')
+ xcb_dep = dependency('xcb', required: get_option('xwayland'))
+
diff --git a/gui-wm/hyprland/files/hyprland-0.28.0-no-wlroots-automagic.patch b/gui-wm/hyprland/files/hyprland-0.28.0-no-wlroots-automagic.patch
deleted file mode 100644
index 96b12fe497eb..000000000000
--- a/gui-wm/hyprland/files/hyprland-0.28.0-no-wlroots-automagic.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-# Disable automagic, otherwise wlroots will enable features if dependencies are present.
-diff --git a/meson.build b/meson.build
-index 6a94dee6..9608717d 100644
---- a/meson.build
-+++ b/meson.build
-@@ -39,7 +39,7 @@ add_project_arguments(
- ],
- language: 'cpp')
-
--wlroots = subproject('wlroots', default_options: ['examples=false'])
-+wlroots = subproject('wlroots', default_options: ['backends=drm,libinput,x11','examples=false','renderers=gles2','xcb-errors=disabled'])
- have_xwlr = wlroots.get_variable('features').get('xwayland')
- xcb_dep = dependency('xcb', required: get_option('xwayland'))
-