summaryrefslogtreecommitdiff
path: root/gui-wm/hyprland/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-01 11:42:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-01 11:42:50 +0100
commitb447ac3a6d1bb09ddb6a5686620670e223b37642 (patch)
tree4d6d1ca6d418b0dc7c50e0e94cef5038f5fb2483 /gui-wm/hyprland/files
parent9a92076d428b51966bd8d699427341e5500b3a8a (diff)
gentoo auto-resync : 01:10:2023 - 11:42:49
Diffstat (limited to 'gui-wm/hyprland/files')
-rw-r--r--gui-wm/hyprland/files/hyprland-0.30.0-3400-fix-build.patch49
-rw-r--r--gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch18
2 files changed, 67 insertions, 0 deletions
diff --git a/gui-wm/hyprland/files/hyprland-0.30.0-3400-fix-build.patch b/gui-wm/hyprland/files/hyprland-0.30.0-3400-fix-build.patch
new file mode 100644
index 000000000000..3ee5ca710015
--- /dev/null
+++ b/gui-wm/hyprland/files/hyprland-0.30.0-3400-fix-build.patch
@@ -0,0 +1,49 @@
+From 8637bfb1b79d7778447d93349f14b86dea41d2a4 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Sat, 23 Sep 2023 12:31:37 +0000
+Subject: [PATCH] build: Unbreak build without precompiled headers (#3400)
+
+* helpers: add missing header after 2e34548aea5b
+
+src/helpers/VarList.cpp: In constructor 'CVarList::CVarList(const std::string&, size_t, char, bool)':
+src/helpers/VarList.cpp:19:34: error: 'removeBeginEndSpacesTabs' was not declared in this scope
+ 19 | m_vArgs.emplace_back(removeBeginEndSpacesTabs(in.substr(pos)));
+ | ^~~~~~~~~~~~~~~~~~~~~~~~
+src/helpers/VarList.cpp:23:30: error: 'removeBeginEndSpacesTabs' was not declared in this scope
+ 23 | m_vArgs.emplace_back(removeBeginEndSpacesTabs(std::string_view{s}.data()));
+ | ^~~~~~~~~~~~~~~~~~~~~~~~
+
+* helpers: add missing C linkage after 0dbd99700319
+
+ld.lld: error: undefined symbol: wlr_region_scale(pixman_region32*, pixman_region32 const*, float)
+>>> referenced by Region.cpp
+>>> src/Hyprland.p/helpers_Region.cpp.o:(CRegion::scale(float))
+>>> did you mean: extern "C" wlr_region_scale
+>>> defined in: /usr/lib/libwlroots.so.12032
+---
+ src/helpers/Region.cpp | 2 ++
+ src/helpers/VarList.cpp | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/src/helpers/Region.cpp b/src/helpers/Region.cpp
+index e2db466438..5515e71e7e 100644
+--- a/src/helpers/Region.cpp
++++ b/src/helpers/Region.cpp
+@@ -1,6 +1,8 @@
+ #include "Region.hpp"
++extern "C" {
+ #include <wlr/util/box.h>
+ #include <wlr/util/region.h>
++}
+
+ CRegion::CRegion() {
+ pixman_region32_init(&m_rRegion);
+diff --git a/src/helpers/VarList.cpp b/src/helpers/VarList.cpp
+index c29a1e9641..780ea9a045 100644
+--- a/src/helpers/VarList.cpp
++++ b/src/helpers/VarList.cpp
+@@ -1,3 +1,4 @@
++#include "MiscFunctions.hpp"
+ #include "VarList.hpp"
+ #include <ranges>
+ #include <algorithm>
diff --git a/gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch b/gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch
new file mode 100644
index 000000000000..452c1cc80f5e
--- /dev/null
+++ b/gui-wm/hyprland/files/hyprland-0.30.0-no-wlroots-automagic-r1.patch
@@ -0,0 +1,18 @@
+diff --git a/meson.build b/meson.build
+index d515621e..08993f8a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -39,7 +39,12 @@ add_project_arguments(
+ ],
+ language: 'cpp')
+
+-wlroots = subproject('wlroots', default_options: ['examples=false', 'renderers=gles2'])
++if get_option('xwayland').enabled()
++ wlroots = subproject('wlroots', default_options: ['backends=drm,libinput,x11','examples=false','renderers=gles2','xcb-errors=disabled','xwayland=enabled'])
++else
++ wlroots = subproject('wlroots', default_options: ['backends=drm,libinput','examples=false','renderers=gles2','xcb-errors=disabled','xwayland=disabled'])
++endif
++
+ have_xwlr = wlroots.get_variable('features').get('xwayland')
+ xcb_dep = dependency('xcb', required: get_option('xwayland'))
+