summaryrefslogtreecommitdiff
path: root/kde-apps/ark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
commit0706fc6986773f4e4d391deff4ad5143c464ea4e (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /kde-apps/ark
parentaa3411e241a201d53a2689766fe419f2756819f3 (diff)
Revert "gentoo resync : 24.03.2019"
This reverts commit aa3411e241a201d53a2689766fe419f2756819f3.
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest4
-rw-r--r--kde-apps/ark/ark-18.08.3.ebuild75
-rw-r--r--kde-apps/ark/ark-18.12.3.ebuild2
3 files changed, 79 insertions, 2 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 566c440a7de6..0e8136e5439d 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,3 +1,5 @@
+DIST ark-18.08.3.tar.xz 2580200 BLAKE2B 7ecfcc542d25c0a6ba8639e4a5cd353358d5188077ca309c6fe6dc07288c071083ff7a025d71d489d3fed412c63d69f33d480084afbd015b6c45b64cf08a3286 SHA512 56ec9a592cc0862dfe39dbef424b1fb09e8d32050448558c402b864756e00ba402e9fdec7159e3bd5b7013217f6cf1b33cdd4b0d663a11b8bfe5c4c76535f820
DIST ark-18.12.3.tar.xz 2580024 BLAKE2B a705da9af77ff8fdebbdb2fa3a58fa2a33ccba8a297b6def20ee855b8c5f05ecc90a4f14dc29aae632f8f9dfcb996ea01660ddfd49edce942e042a89b8d51dc1 SHA512 0dc232b004134c048bb516aa43e478545b4052fba9321a6166a3bb4e05638288802f578cea51340c8416257f10e1bcbd55740a8945ae5f95cee6864f107d633f
-EBUILD ark-18.12.3.ebuild 2058 BLAKE2B 2aeafdafafbde3b1a4787c77df5e3c8dee256edb9890ad41bf342844725d21a7fa089d4cc63fad6ce9bd0030e2cb9cb9a7725a254516898ef0ab8938997a69f6 SHA512 1b1e5d710789713021a545a661fc05c8f3cf8c8033fc31ca78f2c6722d68d6f63e7be1b24cc6ed4341a935debbb4a1312043b3b98ee8d5ff86d8888a0bda098f
+EBUILD ark-18.08.3.ebuild 1939 BLAKE2B 2d29d45cd0641f924464fd7114d07efba9e7ee1f8263c1d51acfe9d9eb4a60524902e9b27d9957b59ecad1b0ed7c83203eaa0d774cbeca614fa0ec032dab32ca SHA512 2b264044f2c39f3719f62279a83723ecb768bc044c9ecc4aab0a31b1e97cf4da3f7e9f1c404c698d12c73f80399b3cb0a3fecc09952c7c0c6d3396a222f7caf1
+EBUILD ark-18.12.3.ebuild 2060 BLAKE2B bcc47574a928263767320c035c80022352214c1883483d5ea7d226ac9c6c30c0a07cb5d5bb66f1d6f010a9f5ab8e63feadf2b4e0396fd6ffa723afd873011055 SHA512 0ca4df3cd212d67f549c1d13ff6b04b16675c32c995e289b989e2f48a5f94b3563e3ca25ea9689614f8330069552591a55d8d245e057301674bfb796b0ee8468
MISC metadata.xml 348 BLAKE2B 89cd42a24774f85082d025bc18402e0d4a36e07ab62155b67474a14c7294de3875d078167521f6cc4496f97f311de9264ff8c41e78477101a80d0ae2a034dcaf SHA512 447d60adfaec4e52c25d7a61a281b8b044c9a786a0600b8a8260a150f6842047f45b981aabb75e56255d05a918370113f6d2552fec1b88f661141453e003c472
diff --git a/kde-apps/ark/ark-18.08.3.ebuild b/kde-apps/ark/ark-18.08.3.ebuild
new file mode 100644
index 000000000000..d8cacac9ed3a
--- /dev/null
+++ b/kde-apps/ark/ark-18.08.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="amd64 x86"
+IUSE="bzip2 lzma zip"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "For extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+
+ has_version app-arch/rar || \
+ elog "For creating rar archives, installing app-arch/rar is required."
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+}
diff --git a/kde-apps/ark/ark-18.12.3.ebuild b/kde-apps/ark/ark-18.12.3.ebuild
index 0980761f7a6d..02905aca1514 100644
--- a/kde-apps/ark/ark-18.12.3.ebuild
+++ b/kde-apps/ark/ark-18.12.3.ebuild
@@ -11,7 +11,7 @@ inherit kde5
DESCRIPTION="KDE Archiving tool"
HOMEPAGE="https://www.kde.org/applications/utilities/ark
https://utils.kde.org/projects/ark/"
-KEYWORDS="amd64 ~arm64 x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="bzip2 lzma zip"
BDEPEND="