summaryrefslogtreecommitdiff
path: root/kde-apps/ark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /kde-apps/ark
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest4
-rw-r--r--kde-apps/ark/ark-17.12.0.ebuild76
2 files changed, 79 insertions, 1 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index d35693d331e9..dc34a40cbebc 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,3 +1,5 @@
-DIST ark-17.08.3.tar.xz 1966132 SHA256 dd206ae58946f451d16b5369376b2fe46fa1e6d19d95637aa3a40fd1ec18e3e3 SHA512 c28eda02f561391a21723286de2b71b9d985a07edfabd510b690927ac598da7464b56ba6132bb0362a6fd7ddb35d99bcbeb8ef74b801cfbba22f6f6d91262fb8 WHIRLPOOL 35de7267080b1d3de90135a55421a25ff6280cb7ff2b5bbcbaa5046f963251b3058f3c15355b960e1d66eaaf985a3f3f3fd408fd7095ec198b79bbec5575c7bd
+DIST ark-17.08.3.tar.xz 1966132 BLAKE2B ec17cdd3d9682cbf2f533bb159fcc219c91426997120ac03fa4726123701b6e1d98686cdaa07330e541bd2a1189a920292c13932df824bb9855bc93c38c7c605 SHA512 c28eda02f561391a21723286de2b71b9d985a07edfabd510b690927ac598da7464b56ba6132bb0362a6fd7ddb35d99bcbeb8ef74b801cfbba22f6f6d91262fb8
+DIST ark-17.12.0.tar.xz 1969924 BLAKE2B 98f686d81a0531f670f9a212ed685710eacf9bcf79d865b6690ce1e9401200151d52db00f96acc7cd5aa28100370c01674d7ed23d611bc4f9a27eae2c0d8ee31 SHA512 f4e95fe8fa87e285172ba9a7a51c09fc05684d7f6093dd5059fc04367718d57dc0620c00272242fdc04a0b8be9f9d8d99db56fb21067e39401d80e5576a8a6a8
EBUILD ark-17.08.3.ebuild 1869 BLAKE2B 9abc58e04fac49d6f8e9bf24eb058f59d00f179580e8d56821fbccfcafa90b9f2a46c0c0e909d9ea05d57af1c1ccffbec63a0cbfa3fa16f0ff493b480054525b SHA512 e89980b83e2fed67bb018f49ee75b1f31caa2dc8f9fa848925d3392eafe974a6b9d63df7cc46fe7aa340e562347f7da5efc46a7aa242e8900166296b77ca42cc
+EBUILD ark-17.12.0.ebuild 1886 BLAKE2B 97bc9bfa239298acacbddda8ed7511c1384f610a62d4125d0d9ef4e1429f34fe01adaf75763edb8b3a24a1c1676fcf8664cc035d0b4e83513e1647155dccdc6b SHA512 b79150bb7f72c09df18e532a16c8b1c469369fc64a1a7cc810a313f000a62d5cc793a1efd587bf9e08d056e433d8861c9810dbbcf7f022dad5b649271024e8f2
MISC metadata.xml 348 BLAKE2B 89cd42a24774f85082d025bc18402e0d4a36e07ab62155b67474a14c7294de3875d078167521f6cc4496f97f311de9264ff8c41e78477101a80d0ae2a034dcaf SHA512 447d60adfaec4e52c25d7a61a281b8b044c9a786a0600b8a8260a150f6842047f45b981aabb75e56255d05a918370113f6d2552fec1b88f661141453e003c472
diff --git a/kde-apps/ark/ark-17.12.0.ebuild b/kde-apps/ark/ark-17.12.0.ebuild
new file mode 100644
index 000000000000..7b43f18dbf93
--- /dev/null
+++ b/kde-apps/ark/ark-17.12.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}