summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-bazaar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /kde-apps/dolphin-plugins-bazaar
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'kde-apps/dolphin-plugins-bazaar')
-rw-r--r--kde-apps/dolphin-plugins-bazaar/Manifest2
-rw-r--r--kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.04.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-bazaar/Manifest b/kde-apps/dolphin-plugins-bazaar/Manifest
index 1f5095606cec..ceb59de43ae5 100644
--- a/kde-apps/dolphin-plugins-bazaar/Manifest
+++ b/kde-apps/dolphin-plugins-bazaar/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-plugins-18.12.3.tar.xz 191992 BLAKE2B 82dc3e03008949bc0af0c5938365b2d4dadbe8cafc0e7969e8c3a05804a53bfe6feb5e62e2f90f98940150709834472ff5b642681c7a6386b6362df8e4e75726 SHA512 a7d022652d80e832209c507b293c2701a8a3537d2b494e72c1e09dda9159751be8287991441869c0ce4cb8346c8c11fa537e94e06effb8e02d4f9f1fedaf9bf7
+DIST dolphin-plugins-19.04.0.tar.xz 192060 BLAKE2B 9024f60355f18e4961b5df543789f7c92501ff4162bea235760f47c5870e018fa42f092e4b3896ae470406f3b37b0171f814a48d246f085f377f215b8964f0ad SHA512 a9b8104f6472053f5e7b95a53238a2673d819a025b878a998c17c017683a1d61adbdd0abef6a40a4f3257735e2c16ca5a7550e95fe0bfa99ae470f3a4fe30ed5
EBUILD dolphin-plugins-bazaar-18.12.3.ebuild 1033 BLAKE2B 7b001661bbb56e15e7f6fbd391bb3ba4c56e839b8efaf38f2b901c032464ebe876eeae50740dd0663f7f66759d638e9afe6f0b828fe60ad1bf90da281154855e SHA512 8fa0198b4573cb69356b01b53fd996fede5cf9addeb764da7f394123e5be41701cf28d59e92dc8b254157ebc67b43d96d21bc4b1b8c8c79547fa454cd7e34682
+EBUILD dolphin-plugins-bazaar-19.04.0.ebuild 1035 BLAKE2B 50f90b5ff584789b37a0e31f042523ad387965a1d05c2d45235272911d07ce8b57ed3134b93836d6cf39fb0ff8b3cb3038b540b7095800bbcb51efd5f05f77f6 SHA512 ade5cba4fe3803b66e3b6a2ab0c75e03a65be0fa684ed8d0baa4b3d81abd3cbf91abad196a42d6763c8eb7ea7e5b0620429d0b036000192e8b1266d728bd0b23
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.04.0.ebuild b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.04.0.ebuild
new file mode 100644
index 000000000000..457b91d305a0
--- /dev/null
+++ b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.04.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="bazaar"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Bazaar integration"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/bzr
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ punt_bogus_dep Qt5 Network
+ punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}