summaryrefslogtreecommitdiff
path: root/kde-apps/konsole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 14:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 14:10:02 +0100
commit7e17b5aabc330abb894f2b90bef0e3fcbcd180d2 (patch)
tree0b0cd08ce6e24faf7c868b07127ee0b6b32153c7 /kde-apps/konsole
parentda3552023d9aae2ee5183df71a80a8169414974e (diff)
gentoo auto-resync : 06:08:2022 - 14:10:01
Diffstat (limited to 'kde-apps/konsole')
-rw-r--r--kde-apps/konsole/Manifest3
-rw-r--r--kde-apps/konsole/files/konsole-22.04.3-without_x11.patch46
-rw-r--r--kde-apps/konsole/konsole-22.04.3.ebuild5
3 files changed, 51 insertions, 3 deletions
diff --git a/kde-apps/konsole/Manifest b/kde-apps/konsole/Manifest
index c4cc54bf00a8..95e48a74c861 100644
--- a/kde-apps/konsole/Manifest
+++ b/kde-apps/konsole/Manifest
@@ -1,3 +1,4 @@
+AUX konsole-22.04.3-without_x11.patch 1557 BLAKE2B 27d2ebb2dc65886938a083a92097716d5ffa5a46485deecf183dfdd5d565c3f67244516a6ce6299cf1e48ef9c20bcd59add50b99c28c54a9b13182f469344b85 SHA512 b28e4dd052d93e731990f21741195cd40e0bfb433aaa2c664881b1fb0944dce5fa3b061e01ac64a773674a030042f16e7a492ac84dd7d52308a69c0a019cc0f6
DIST konsole-22.04.3.tar.xz 1476120 BLAKE2B 6675955b6c2257d342e7560c759c95fe19301f76c72db6c542275acc879b78606eeb17893111930d575290048cb9047c7b42b8af7b60169d6995ae0efd03fd35 SHA512 05728efc051ae76b395c7ece1599e654ce3bdae0c8b43d7f8e34c76f57041f7722e161147c4a5699377b764aa8b3799421d5c735967216c5420b6f92330c1338
-EBUILD konsole-22.04.3.ebuild 1702 BLAKE2B 61eadeea4359d8f5cbfe2fa5df09617b3c73a6ba1f1982c50a68fe317188702fae47da71f16f521c233aa14fce286f869a9044febfb1a5845b1f8320be54ed88 SHA512 4d07e4c6371ee1090ad284751e5ebdd1d47e9002f34fa99ca4d5ad60da865d0950b6b27ace4e869418658e78723e0795d9ed30910451cc65549ec8ffd0f6e36b
+EBUILD konsole-22.04.3.ebuild 1744 BLAKE2B 5c4d12873b7ad40c6d59ea430f8dffe63e500459b15b1bd358b4ada318e6d23bdd4c2d98a58fdb3a47270579090c20bb5a7ed5de5e7fc27d1a7aca67cdaaa8dc SHA512 57799a93af9af3a7df8da4ae37d8a466f00a2dadcdb580d1b7168a2df2448dee19a86cc6a5bbc2e2c35b5dff57661a55d418d5512f35c30b6e90cad3273ee29b
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch b/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch
new file mode 100644
index 000000000000..ed396fcf20ab
--- /dev/null
+++ b/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch
@@ -0,0 +1,46 @@
+From 0aa39e22a2bb1bbcb8a02dfd6635ffe4d8a0bbb1 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 Nov 2021 14:43:18 +0100
+Subject: [PATCH] Add CMake option to build WITHOUT_X11
+
+We want to be able to build without X11 support even if some of the used
+libraries may not work w/o X11 themselves yet or need to be built with
+X11 support for other reverse dependencies.
+
+HAVE_X11 already exists and is set automagically so far, but using
+-DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
+as required in their cmake config.
+
+Introducing this option means there is no behavior change by default,
+cmake will just skip finding X11 or adding unwanted features if the
+option is enabled.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 61ed70cd7..565682848 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -103,10 +103,13 @@ set_package_properties(KF5DocTools PROPERTIES DESCRIPTION
+ )
+
+ if(NOT APPLE)
+- find_package(X11)
+- set_package_properties(X11 PROPERTIES TYPE OPTIONAL)
++ option(WITHOUT_X11 "Build without X11 integration (skips finding X11)" OFF)
++ if (NOT WITHOUT_X11)
++ find_package(X11)
++ set_package_properties(X11 PROPERTIES TYPE OPTIONAL)
++ set(HAVE_X11 ${X11_FOUND})
++ endif()
+ endif()
+-set(HAVE_X11 ${X11_FOUND})
+
+ # Check for function GETPWUID
+ check_symbol_exists(getpwuid "pwd.h" HAVE_GETPWUID)
+--
+GitLab
+
diff --git a/kde-apps/konsole/konsole-22.04.3.ebuild b/kde-apps/konsole/konsole-22.04.3.ebuild
index cce03a53b3c6..d02a5534dca2 100644
--- a/kde-apps/konsole/konsole-22.04.3.ebuild
+++ b/kde-apps/konsole/konsole-22.04.3.ebuild
@@ -50,11 +50,12 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-without_x11.patch" )
+
src_configure() {
local mycmakeargs=(
- $(cmake_use_find_package X X11)
+ -DWITHOUT_X11=$(usex !X)
)
-
ecm_src_configure
}