summaryrefslogtreecommitdiff
path: root/kde-apps/libkgapi/libkgapi-19.04.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /kde-apps/libkgapi/libkgapi-19.04.2.ebuild
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'kde-apps/libkgapi/libkgapi-19.04.2.ebuild')
-rw-r--r--kde-apps/libkgapi/libkgapi-19.04.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-apps/libkgapi/libkgapi-19.04.2.ebuild b/kde-apps/libkgapi/libkgapi-19.04.2.ebuild
new file mode 100644
index 000000000000..8fc489120e5c
--- /dev/null
+++ b/kde-apps/libkgapi/libkgapi-19.04.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Library for accessing Google calendar and contact resources"
+HOMEPAGE="https://cgit.kde.org/libkgapi.git"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+ !<kde-apps/kdepim-runtime-18.07.80:5
+"