summaryrefslogtreecommitdiff
path: root/kde-apps/libkgeomap/libkgeomap-18.08.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
commit0706fc6986773f4e4d391deff4ad5143c464ea4e (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /kde-apps/libkgeomap/libkgeomap-18.08.3.ebuild
parentaa3411e241a201d53a2689766fe419f2756819f3 (diff)
Revert "gentoo resync : 24.03.2019"
This reverts commit aa3411e241a201d53a2689766fe419f2756819f3.
Diffstat (limited to 'kde-apps/libkgeomap/libkgeomap-18.08.3.ebuild')
-rw-r--r--kde-apps/libkgeomap/libkgeomap-18.08.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-apps/libkgeomap/libkgeomap-18.08.3.ebuild b/kde-apps/libkgeomap/libkgeomap-18.08.3.ebuild
new file mode 100644
index 000000000000..666ccc69d84d
--- /dev/null
+++ b/kde-apps/libkgeomap/libkgeomap-18.08.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Wrapper library for world map components as marble, openstreetmap and googlemap"
+HOMEPAGE="https://www.digikam.org/"
+
+LICENSE="GPL-2+"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep marble 'kde' '' '5=')
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=true
+ )
+
+ kde5_src_configure
+}