summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcompletion/kcompletion-5.60.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /kde-frameworks/kcompletion/kcompletion-5.60.0.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'kde-frameworks/kcompletion/kcompletion-5.60.0.ebuild')
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.60.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/kcompletion-5.60.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.60.0.ebuild
new file mode 100644
index 000000000000..6c229fd6278d
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.60.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"