summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcompletion/kcompletion-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-28 17:40:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-28 17:40:55 +0000
commit8294b197c0de9084d8ac8510382353ea4c177b87 (patch)
tree588533368704fdb760c55c9d15e246a827bc3e3d /kde-frameworks/kcompletion/kcompletion-6.0.0.ebuild
parent73c06e01ebc820f47f0140310b8a096e9d20877b (diff)
gentoo auto-resync : 28:02:2024 - 17:40:54
Diffstat (limited to 'kde-frameworks/kcompletion/kcompletion-6.0.0.ebuild')
-rw-r--r--kde-frameworks/kcompletion/kcompletion-6.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/kcompletion-6.0.0.ebuild b/kde-frameworks/kcompletion/kcompletion-6.0.0.ebuild
new file mode 100644
index 000000000000..540f12bb312b
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-6.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ =kde-frameworks/kcodecs-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"