summaryrefslogtreecommitdiff
path: root/kde-frameworks/kimageformats/kimageformats-5.99.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
commit533ce9c954925ca2a6bccd1f52f266e81e61a678 (patch)
treeef0ef849f69e60394f4bbbab166e6b83848f609c /kde-frameworks/kimageformats/kimageformats-5.99.0-r3.ebuild
parent9a8514e070a40648dbc8e28ad6457d925542b79a (diff)
gentoo auto-resync : 26:10:2022 - 15:55:57
Diffstat (limited to 'kde-frameworks/kimageformats/kimageformats-5.99.0-r3.ebuild')
-rw-r--r--kde-frameworks/kimageformats/kimageformats-5.99.0-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-frameworks/kimageformats/kimageformats-5.99.0-r3.ebuild b/kde-frameworks/kimageformats/kimageformats-5.99.0-r3.ebuild
new file mode 100644
index 000000000000..feebf9696329
--- /dev/null
+++ b/kde-frameworks/kimageformats/kimageformats-5.99.0-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework providing additional format plugins for Qt's image I/O system"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="avif eps heif jpegxl openexr raw"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ avif? ( >=media-libs/libavif-0.8.2:= )
+ eps? ( >=dev-qt/qtprintsupport-${QTMIN}:5 )
+ heif? ( >=media-libs/libheif-1.10.0:= )
+ jpegxl? ( media-libs/libjxl )
+ openexr? ( >=media-libs/openexr-3:= )
+ raw? ( media-libs/libraw:= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( src/imageformats/AUTHORS )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-avif-perf-{1,2,3}.patch
+ "${FILESDIR}"/${P}-avif-0.11.0.patch
+ "${FILESDIR}"/${P}-jxl-perf.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DKIMAGEFORMATS_JXL=$(usex jpegxl)
+ $(cmake_use_find_package avif libavif)
+ $(cmake_use_find_package eps Qt5PrintSupport)
+ -DKIMAGEFORMATS_HEIF=$(usex heif)
+ $(cmake_use_find_package openexr OpenEXR)
+ $(cmake_use_find_package raw LibRaw)
+ )
+ ecm_src_configure
+}