summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwallet/kwallet-5.105.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-08 17:32:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-08 17:32:36 +0100
commit02f2b9c649c1687088b6ccb6d30b35f519f107cf (patch)
tree0465ff79d2692a3e01db8bb1ab412adbbf744854 /kde-frameworks/kwallet/kwallet-5.105.0.ebuild
parent74cd29ea4467291ea2c34971de87d6bdc21233e9 (diff)
gentoo auto-resync : 08:04:2023 - 17:32:35
Diffstat (limited to 'kde-frameworks/kwallet/kwallet-5.105.0.ebuild')
-rw-r--r--kde-frameworks/kwallet/kwallet-5.105.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/kwallet-5.105.0.ebuild b/kde-frameworks/kwallet/kwallet-5.105.0.ebuild
new file mode 100644
index 000000000000..671751fa28fa
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.105.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gpg +man"
+
+DEPEND="
+ >=app-crypt/qca-2.3.1:2[qt5(+)]
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X]
+ gpg? ( >=app-crypt/gpgme-1.7.1:=[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" kde-plasma/kwallet-pam
+ optfeature "KWallet management" kde-apps/kwalletmanager:5
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}