summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwallet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
commita2f7cdda45fadf1f967379421e8d808b1a503cd3 (patch)
treec02c7db0bb9249243aa73a4098a17e13daaaff21 /kde-frameworks/kwallet
parent66611e742171c343d64095516e19737d4753ba61 (diff)
gentoo auto-resync : 18:08:2023 - 15:36:15
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest2
-rw-r--r--kde-frameworks/kwallet/kwallet-5.109.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index 1372caf90a96..c60b446c92a9 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,3 +1,5 @@
DIST kwallet-5.108.0.tar.xz 349548 BLAKE2B 67312e5887f897a9664308bd89c15871a9ef56df1196b59633a3c691764c111e657e403c9e5e0b9cab1c6b070c137095d0552f391bee7fca150cb3cc6274dd71 SHA512 ba129b8f20d1fc853075735127394629daafefd9c1c42d0a657a82ffc1634bcfa36ceddea98ac1e21fda1a4db842ae9e681cc87153571fedb3a596638d62fed7
+DIST kwallet-5.109.0.tar.xz 349624 BLAKE2B 23500a7cec6df5a0a2240fdbdfb4a54859569dc9e00b3c8bbc493f03edd55aab6afb78377511737349df9233e0badc2235ecebf1feca7f2f46591749b848e936 SHA512 6e986eba26c5a8f783bcd1b6fb6395c20039d16c19cf81a2f568c8c9eb20c18e17aeb28f5435a89d325a46b17faf8063814c591a17d31bf5538acb4103b7e577
EBUILD kwallet-5.108.0.ebuild 1437 BLAKE2B c28f2ce44ab50d847a108d7c66dc78df0029fc4df9a9f4468f8c798750dfc669ed8ec7f0e64896e7d4885d001036b08b64132d028c41cea39e1e3d294dbed608 SHA512 de0de8dec6edc0decc5e1c4390543870a0df04d189de7d572519e31599279b257bc60f63c8e7bf1387f647417877f3ba8a0cf384139476a69dc0a86e3eaee133
+EBUILD kwallet-5.109.0.ebuild 1428 BLAKE2B 00810eb67817272cf2df7108b8f42f0bdff9da9c8890c94e99b80a7d12dc7c033ad3b104ca83c4f32d00ca6209ca229eddd26a27f2f21f06c5f118647624d2ce SHA512 25ce1be1b9fce2f425ee1c14819c08928ca1e596c9c5e7849037c954df61105a2f280e25f87a32ff3f7460ec9ee1eb99c8b78ae362c4cac86e957b6987fd0992
MISC metadata.xml 586 BLAKE2B 7ab7b780f8861068d289d9563a6a81ee660265764db00a7be316a1242fc56689af895248783ee8814b95f46ce35bfa7533d511b2c47b1170b46ae0ba96aa92e5 SHA512 f0d5748631151406a2baf5401386cf644a8d373651e44858f336741a8eecffe1b3c2967b10925fdd9490a050740b3f9eba781f2aacee13fcd211c3145c625a3c
diff --git a/kde-frameworks/kwallet/kwallet-5.109.0.ebuild b/kde-frameworks/kwallet/kwallet-5.109.0.ebuild
new file mode 100644
index 000000000000..3089f22bf4c6
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.109.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv"
+IUSE="gpg +man"
+
+DEPEND="
+ >=app-crypt/qca-2.3.1:2[qt5(+)]
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X]
+ gpg? ( >=app-crypt/gpgme-1.7.1:=[cxx,qt5] )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" kde-plasma/kwallet-pam
+ optfeature "KWallet management" kde-apps/kwalletmanager:5
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}