summaryrefslogtreecommitdiff
path: root/kde-frameworks/plasma/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 20:39:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 20:39:44 +0100
commit54eca75a4e3e380e1d386f4d235baeb7d4ff332e (patch)
tree5f59a3e7b9069e5ab5ae4c5b46184560dc318692 /kde-frameworks/plasma/files
parentfc7e841956ae3cc385629bf33433de23a6d04db6 (diff)
gentoo auto-resync : 19:07:2022 - 20:39:44
Diffstat (limited to 'kde-frameworks/plasma/files')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.95.0-fix-sizeForLabels-double-scaling.patch38
-rw-r--r--kde-frameworks/plasma/files/plasma-5.95.0-revert-QT_FEATURE_foo.patch42
2 files changed, 0 insertions, 80 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.95.0-fix-sizeForLabels-double-scaling.patch b/kde-frameworks/plasma/files/plasma-5.95.0-fix-sizeForLabels-double-scaling.patch
deleted file mode 100644
index 84022d815b55..000000000000
--- a/kde-frameworks/plasma/files/plasma-5.95.0-fix-sizeForLabels-double-scaling.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 26ae86dff198fbce05ba3824b89786224b3792a9 Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Thu, 23 Jun 2022 12:47:32 -0600
-Subject: [PATCH] Units: Fix sizeForLabels double-scaling icons with Plasma
- scaling
-
-The sizeForLabels unit internally uses roundToIconSize(), giving it a
-value and feeding that into devicePixelIconSize() to take into account
-required icons size differences when using Plasma scaling. But
-roundToIconSize() internally does that automatically! So as a result,
-the size is double-scaled and looks too big. To fix this, we simply have
-to stop using devicePixelIconSize() for this unit.
-
-BUG: 454131
-FIXED-IN: 5.96
----
- src/declarativeimports/core/units.cpp | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/declarativeimports/core/units.cpp b/src/declarativeimports/core/units.cpp
-index 0cdffcbfd..8d655d11f 100644
---- a/src/declarativeimports/core/units.cpp
-+++ b/src/declarativeimports/core/units.cpp
-@@ -115,8 +115,9 @@ void Units::iconLoaderSettingsChanged()
- m_iconSizes->insert(QStringLiteral("large"), devicePixelIconSize(KIconLoader::SizeLarge));
- m_iconSizes->insert(QStringLiteral("huge"), devicePixelIconSize(KIconLoader::SizeHuge));
- m_iconSizes->insert(QStringLiteral("enormous"), devicePixelIconSize(KIconLoader::SizeEnormous));
-- // gridUnit is always the font height here
-- m_iconSizes->insert(QStringLiteral("sizeForLabels"), devicePixelIconSize(roundToIconSize(QFontMetrics(QGuiApplication::font()).height())));
-+ // We deliberately don't feed the result into devicePixelIconSize() because
-+ // roundToIconSize() already does that internally.
-+ m_iconSizes->insert(QStringLiteral("sizeForLabels"), roundToIconSize(QFontMetrics(QGuiApplication::font()).height()));
-
- m_iconSizeHints->insert(QStringLiteral("panel"), devicePixelIconSize(KIconLoader::global()->currentSize(KIconLoader::Panel)));
- m_iconSizeHints->insert(QStringLiteral("desktop"), devicePixelIconSize(KIconLoader::global()->currentSize(KIconLoader::Desktop)));
---
-GitLab
-
diff --git a/kde-frameworks/plasma/files/plasma-5.95.0-revert-QT_FEATURE_foo.patch b/kde-frameworks/plasma/files/plasma-5.95.0-revert-QT_FEATURE_foo.patch
deleted file mode 100644
index 300612763336..000000000000
--- a/kde-frameworks/plasma/files/plasma-5.95.0-revert-QT_FEATURE_foo.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From dff1b034c1162062aa2292099d3d01fc53dafdf6 Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Tue, 14 Jun 2022 14:05:32 +0200
-Subject: [PATCH] Revert "Use QT_FEATURE_foo to detect opengl* support, and
- TARGET for glesv2"
-
-This reverts commit 31884dc195c815054bfa6b15a90753d2d0ae1ea9.
----
- CMakeLists.txt | 3 ++-
- src/declarativeimports/core/CMakeLists.txt | 2 +-
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 6698a2091..63229cdfb 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -118,7 +118,8 @@ set_package_properties(EGL PROPERTIES
- TYPE OPTIONAL
- )
-
--if(OpenGL_GLX_FOUND AND X11_FOUND AND QT_FEATURE_opengl)
-+get_target_property(QtGui_Enabled_Features Qt${QT_MAJOR_VERSION}::Gui QT_ENABLED_PUBLIC_FEATURES)
-+if(OpenGL_GLX_FOUND AND X11_FOUND AND (QtGui_Enabled_Features MATCHES "opengl"))
- add_feature_info(GLX OpenGL_GLX_FOUND "OpenGL GLX libraries.")
- set(HAVE_GLX 1)
- else()
-diff --git a/src/declarativeimports/core/CMakeLists.txt b/src/declarativeimports/core/CMakeLists.txt
-index d08b4c619..2136bb985 100644
---- a/src/declarativeimports/core/CMakeLists.txt
-+++ b/src/declarativeimports/core/CMakeLists.txt
-@@ -70,7 +70,7 @@ else()
-
- endif()
-
--if(TARGET Qt${QT_MAJOR_VERSION}::Gui_GLESv2)
-+if(QtGui_Enabled_Features MATCHES "opengles2")
- target_link_libraries(corebindingsplugin Qt${QT_MAJOR_VERSION}::Gui_GLESv2)
- endif()
-
---
-GitLab
-