summaryrefslogtreecommitdiff
path: root/kde-frameworks/prison/prison-5.70.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /kde-frameworks/prison/prison-5.70.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'kde-frameworks/prison/prison-5.70.0.ebuild')
-rw-r--r--kde-frameworks/prison/prison-5.70.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/prison/prison-5.70.0.ebuild b/kde-frameworks/prison/prison-5.70.0.ebuild
new file mode 100644
index 000000000000..ea1ffc8cdec5
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.70.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://cgit.kde.org/prison.git"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt5Quick)
+ )
+
+ ecm_src_configure
+}