summaryrefslogtreecommitdiff
path: root/kde-frameworks/syntax-highlighting/syntax-highlighting-5.114.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-15 01:16:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-15 01:16:32 +0000
commit7387c23ff485f2416512185bf64584028335b993 (patch)
tree77f6578297f64937d732133db350b968dfe538e3 /kde-frameworks/syntax-highlighting/syntax-highlighting-5.114.0.ebuild
parentd8a50857c27d3253561374390ac9ed8c1b65d9bc (diff)
gentoo auto-resync : 15:01:2024 - 01:16:32
Diffstat (limited to 'kde-frameworks/syntax-highlighting/syntax-highlighting-5.114.0.ebuild')
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.114.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.114.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.114.0.ebuild
new file mode 100644
index 000000000000..5f772b6dfcc3
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.114.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5"
+BDEPEND="
+ dev-lang/perl
+ >=dev-qt/linguist-tools-${QTMIN}:5
+"