summaryrefslogtreecommitdiff
path: root/kde-misc/plasma-pass/plasma-pass-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /kde-misc/plasma-pass/plasma-pass-1.0.0.ebuild
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'kde-misc/plasma-pass/plasma-pass-1.0.0.ebuild')
-rw-r--r--kde-misc/plasma-pass/plasma-pass-1.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-misc/plasma-pass/plasma-pass-1.0.0.ebuild b/kde-misc/plasma-pass/plasma-pass-1.0.0.ebuild
new file mode 100644
index 000000000000..d1ea19ba7f7f
--- /dev/null
+++ b/kde-misc/plasma-pass/plasma-pass-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Plasma applet to access password from pass"
+HOMEPAGE="https://www.dvratil.cz/2018/05/plasma-pass/ https://cgit.kde.org/plasma-pass.git/"
+
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgraphicaleffects)
+ $(add_qt_dep qtgui)
+"
+RDEPEND="${DEPEND}
+ $(add_frameworks_dep kirigami)
+"