summaryrefslogtreecommitdiff
path: root/kde-misc/rsibreak/rsibreak-0.12.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /kde-misc/rsibreak/rsibreak-0.12.10-r1.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'kde-misc/rsibreak/rsibreak-0.12.10-r1.ebuild')
-rw-r--r--kde-misc/rsibreak/rsibreak-0.12.10-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-misc/rsibreak/rsibreak-0.12.10-r1.ebuild b/kde-misc/rsibreak/rsibreak-0.12.10-r1.ebuild
new file mode 100644
index 000000000000..b65ba4d41255
--- /dev/null
+++ b/kde-misc/rsibreak/rsibreak-0.12.10-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Small utility which bothers you at certain intervals"
+HOMEPAGE="https://userbase.kde.org/RSIBreak"
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="sys-devel/gettext"
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+# bug 587170 for frameworkintegration
+RDEPEND="${DEPEND}
+ $(add_frameworks_dep frameworkintegration)
+"
+
+PATCHES=( "${FILESDIR}/${P}-desktopentry.patch" )