summaryrefslogtreecommitdiff
path: root/kde-plasma/breeze-gtk/breeze-gtk-5.27.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-04 23:23:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-04 23:23:41 +0100
commit3b4ca161c9d7f5a66a93191da2c9ec02dbdde1b7 (patch)
tree05ee189fbf7a80ad6a8a565742051527322cbbdd /kde-plasma/breeze-gtk/breeze-gtk-5.27.4.ebuild
parent0f3400581b3370a12b1581c6394b74327181f3e8 (diff)
gentoo auto-resync : 04:04:2023 - 23:23:40
Diffstat (limited to 'kde-plasma/breeze-gtk/breeze-gtk-5.27.4.ebuild')
-rw-r--r--kde-plasma/breeze-gtk/breeze-gtk-5.27.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-plasma/breeze-gtk/breeze-gtk-5.27.4.ebuild b/kde-plasma/breeze-gtk/breeze-gtk-5.27.4.ebuild
new file mode 100644
index 000000000000..7f10a4930ec9
--- /dev/null
+++ b/kde-plasma/breeze-gtk/breeze-gtk-5.27.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-3)
+PYTHON_COMPAT=( python3_{9..11} )
+inherit ecm plasma.kde.org python-any-r1
+
+DESCRIPTION="Official GTK+ port of Plasma's Breeze widget style"
+HOMEPAGE="https://invent.kde.org/plasma/breeze-gtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/sassc
+ $(python_gen_any_dep 'dev-python/pycairo[${PYTHON_USEDEP}]')
+ >=kde-plasma/breeze-${PVCUT}:5
+"
+
+python_check_deps() {
+ python_has_version "dev-python/pycairo[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ ecm_pkg_setup
+}