summaryrefslogtreecommitdiff
path: root/kde-plasma/kinfocenter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /kde-plasma/kinfocenter
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest2
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.16.0.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index aeea033d6625..a7837dbc9016 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,5 +1,7 @@
AUX kcm-about-distrorc 108 BLAKE2B 9324829040a699d8858a739b228b14035f8a33d4cc5e19af30545a6eb9780808b3350ca12c82a44a1868c32acddd76dcdb4e7b25e5792694b55fbb38ed23db8a SHA512 72f1dcaa04bfe435e64c8e584914eb56a15b63f7c6086f5e025f0c497b4fd5b9592d54aafd335f55d303790af274c9cbfa29c6c7ff87875da648ee16d7717467
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.15.5.tar.xz 1321684 BLAKE2B 51a3b49a5b724d187f58513c87f0618b1ee71d00e4ed51019017ae427602b7135d6bd9419714c431e3440f8a27152c4a72951d929b727f200c5cf1d72fc3ac84 SHA512 d75561edc65701097e4c9249f1cb7208e14ee1e99acbd6521606c99ac8e4ebe9ab42a804d8ef7bcde138d3189e3dbd9aaad088563ae6364418e6119639ac3974
+DIST kinfocenter-5.16.0.tar.xz 1322544 BLAKE2B cd178d65a195ae9e678864dd3d4a93b761446edc5aa34765641972f9452a02cab2cebbba1f17f9ba181f3dc39c3e9db47396622e80addd6886305340469f36b9 SHA512 13729a7417b07a746eadb21e6ac17b793d64f38c24551ff67ebba899932bdca1f860195ea8647b3cdb962367b547b9c85c5966b8f6c575da3eddf6adc41e87cb
EBUILD kinfocenter-5.15.5.ebuild 2589 BLAKE2B d3e7a577e5f2bc418f0dc3783efec94e0572b51e1844c78ccbbb810d6dd7c034274b11263068e70f855363a7d7c6c023f039de212c3289ebd1a1fbe323e95ae6 SHA512 7eb2535a79e4df4207a038870f5f6c2828ce57ca734ae34c3958017a9e1bcac99b9c015af1e6824fc3167e8235d536715140af9963448e6fc478b1411a38a754
+EBUILD kinfocenter-5.16.0.ebuild 2576 BLAKE2B cbbcc58ac4d02e5c2157cf3630e69d5ede215b81bd21e33a0a01c5a751033fcaa3c0e5184913768c02380297817e39b01e0078b0e1406bfb57187bdefc5cd594 SHA512 8191ee295791ece51d585179a008eb8651945ee32fb464e31ddb38545903eec10693702d6bc8ef89e54c896177ea4c21d6eb5ce921b27a8e521156a17d0dd15a
MISC metadata.xml 390 BLAKE2B a47af94b17ade0ad2f4b4a44bac8ac1245c29a6551a059c95967ce2d5cd4420a975210bf0e4658c2152aaf5a894f934cac0d35aae015368bf1f8f8b1cbbbb069 SHA512 4ea690f0f5ac41b58d840949297d462e0fa7433bdece54d63b08a913d8a9001bf6d144e28d5e672712abf35e784c2b17faf31f0a879d6109417ce95ccdc0ef3b
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.16.0.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.16.0.ebuild
new file mode 100644
index 000000000000..084102a9d35d
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.16.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MIN_VERSION=3.14.3
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ $(add_qt_dep qtquickcontrols2)
+ !kde-apps/kcontrol:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "net-fs/nfs-utils" || \
+ elog "Installing net-fs/nfs-utils will enable the NFS information module."
+
+ has_version "net-fs/samba" || \
+ elog "Installing net-fs/samba will enable the Samba status information module."
+ fi
+}