summaryrefslogtreecommitdiff
path: root/kde-plasma/kinfocenter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-02 06:31:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-02 06:31:11 +0000
commitff733bfb4d0bd82175e03255004faef8721b53ea (patch)
treec1061dbb981bc9e61d4f31b6610569711c7b482f /kde-plasma/kinfocenter
parentc4d4d544a37efc45bd5482e62e1fcdbe7d5993d3 (diff)
gentoo auto-resync : 02:01:2025 - 06:31:11
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest2
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-6.2.5.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index cdd82e545ec9..29336c6338c6 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,5 +1,7 @@
AUX kcm-about-distrorc 108 BLAKE2B 9324829040a699d8858a739b228b14035f8a33d4cc5e19af30545a6eb9780808b3350ca12c82a44a1868c32acddd76dcdb4e7b25e5792694b55fbb38ed23db8a SHA512 72f1dcaa04bfe435e64c8e584914eb56a15b63f7c6086f5e025f0c497b4fd5b9592d54aafd335f55d303790af274c9cbfa29c6c7ff87875da648ee16d7717467
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-6.2.4.tar.xz 731644 BLAKE2B 611485573cfc07c48268d1398e19a8d169e53feefbd929cd14c33657d8de0e3e00eb8d61e8f7ef9dbf2034029b9b16fa64eedc92c0cb012b6dcb80e68ab121a2 SHA512 11b0d6be7c8a4b9bea8618abbe859695d0dd2a41c1347bbad7c5b9ee87c0f37440c3afbf6f6f781ff5d4e55064fdf6f2213b8b95fd22a76906f1008ac252533f
+DIST kinfocenter-6.2.5.tar.xz 732392 BLAKE2B 13e583696bcebda5a26935b66619314fa723c60463e5350963acaa6982ce8315c82355c911ae32b8c6ca4ee4832f017cb009fbd5e3b5a36f9f4c95a914a146fa SHA512 dba69043aa09df314275b9cbc6b3aed858dd3bab62381b8fdf83f8aad167581a06ff44a14f9f4cdefb4e205b088065dbdefb7e0fb78fb30508314ed929f3c669
EBUILD kinfocenter-6.2.4.ebuild 2706 BLAKE2B feb03f2374777e3dcd42c8555e9087a33d02d7716bd868dde4425598a2186d0ab647ab0ef65a4b4b7ced46c2802601637717fe0c7bfaadaf1504d290eb210d79 SHA512 43f573f25cfa5c9716dc60ef6beedc0c245a8112984b436ae44b42f16d0c4b98fd8905d6220ebaa224d7fe16a4aa3673d9dd9883ae97a85c87060ad75f065294
+EBUILD kinfocenter-6.2.5.ebuild 2643 BLAKE2B 1a6d2cdcc2b4b91a7261521b8fc58b4c4bc5eab4deff599bbcd3553c0d7073016f7de93d075ddcdcbe8d09094807b6c84f224ea4241be3d7f3123537d07a36cb SHA512 e22e7bcaf5c5e306b5bb3a2b541894bfa638b19d87c606a2333c7d386fa683d875ea66a51a8ddfee7e78fabbc554e7ffc069cb541466a6880adc6a13661475fd
MISC metadata.xml 387 BLAKE2B f03ad4c31bb639282d7c79e13fe8e6a79979350e30c7894bd7d83d80ae30358743ba87e8d6356dcc4fe97a51b8859e8185b779e811a4548e38e4f78f1c27446f SHA512 85da5fc7415747c5eece521eb789eb164153637144b15dc900121320f38f9e7ce3b857c38e18401a9710a9818a81260a6b90b5cc55fb63a409aba8c35e3f082b
diff --git a/kde-plasma/kinfocenter/kinfocenter-6.2.5.ebuild b/kde-plasma/kinfocenter/kinfocenter-6.2.5.ebuild
new file mode 100644
index 000000000000..9704e2d482f1
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-6.2.5.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=6.6.0
+QTMIN=6.7.2
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gles2-only=,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ gles2-only? ( >=media-libs/mesa-24.1.0_rc1[opengl] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ || (
+ >=dev-qt/qttools-${QTMIN}:6[qdbus]
+ dev-qt/qdbus:*
+ )
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-plasma/systemsettings-${KDE_CATV}:6
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+CMAKE_SKIP_TESTS=(
+ # bug 816591
+ smbmountmodeltest
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ -DCMAKE_DISABLE_FIND_PACKAGE_SeleniumWebDriverATSPI=ON # missing
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature_header "Query network filesystem info:"
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature_header "Query firmware/hardware info:"
+ fi
+ optfeature "System DMI table readout" sys-apps/dmidecode
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ optfeature_header "Query GPU/graphics support info:"
+ fi
+ optfeature "OpenCL information module" dev-util/clinfo
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ fi
+ ecm_pkg_postinst
+}