summaryrefslogtreecommitdiff
path: root/kde-plasma/kwayland-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /kde-plasma/kwayland-integration
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest2
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.22.90.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 855604618ee8..c97ba3127410 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,3 +1,5 @@
DIST kwayland-integration-5.22.5.tar.xz 22708 BLAKE2B 61e084dd71721b556fc9bf0aafe92908c25070d1f8683ae53093ca413b0e81efb1c21a3fbb7c033c1e324b2032c8fe9946287eadd53607ee549944f06d081932 SHA512 456b745e493965781178e1cd2fe64b8833294800ea152f5f95d00e1e2c221f97c2a29b91498573bc25710e3ad42482e46a4f0f33d5a57ce8ed1454a65fba81a9
+DIST kwayland-integration-5.22.90.tar.xz 24164 BLAKE2B 6be1c6558ead14b0e892e579f52b85d0379deca89da80d1e0add3669750bd59e478a65dfd71010824ce0dc2aa1e32b57ccca90eeaf07defc342768efa434e5d9 SHA512 f442125728966bfe09fda859b642af71ac0d33526391828d98854d372a4d82f69c6b2f844ac591de539f72f25fefadd5b0d7c714e5d283f57dea0bbb05ef39cf
EBUILD kwayland-integration-5.22.5.ebuild 704 BLAKE2B e0647cfe117a55aea8eaf9725bac8ac906109b2a0041eb56bd0dea4abe17030651a66d59d8ad9ea71eb5ccd7d404854217016651b6ffcdf20b9bc74e85f9a89b SHA512 9a17512299f866f7d15f5f403a2f83707ac28a203f91f61e7dd873472d1a7d17f3fb330cc5e4f74a715b6cf970c45a291366dc9cbba7491129f8367e15844108
+EBUILD kwayland-integration-5.22.90.ebuild 1017 BLAKE2B 7466406ca996f123015d2de0d9e9ecc29cf5bf9bc5931c56fc9941265b1d89c87b78b45a686d59ffe3161483638301232cbf8f1c577dacf46957389c91d07415 SHA512 5e03fa027c46eff70c89349e27cfcccc5c9e089804a19011cc6e7a9659b8bdfefb76386d7bcf4f4c526f1d50c68a40de6d0471c9af8394c954634d7a9b4419fb
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.22.90.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.22.90.ebuild
new file mode 100644
index 000000000000..09e3b1f2b59a
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.22.90.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Provides integration plugins for various KDE frameworks for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RESTRICT="test" # bug 668872
+
+# slot op: includes Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+DEPEND="
+ >=dev-libs/wayland-1.15
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/kidletime-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"