summaryrefslogtreecommitdiff
path: root/kde-plasma/kwin/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-20 17:12:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-20 17:12:31 +0100
commit5370380f5749c1063166b14034ba5962b46c060e (patch)
treecb9b72af235b505f9e30ac2edd9fc2ef294eb358 /kde-plasma/kwin/files
parent2ce67506e52bee4f16032b08b1be9cee9e84e10d (diff)
gentoo auto-resync : 20:09:2023 - 17:12:31
Diffstat (limited to 'kde-plasma/kwin/files')
-rw-r--r--kde-plasma/kwin/files/kwin-5.27.8-cmake.patch40
-rw-r--r--kde-plasma/kwin/files/kwin-5.27.8-crashfix.patch39
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/kwin/files/kwin-5.27.8-cmake.patch b/kde-plasma/kwin/files/kwin-5.27.8-cmake.patch
new file mode 100644
index 000000000000..4c4634140be9
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-5.27.8-cmake.patch
@@ -0,0 +1,40 @@
+From bd41dd93f37df79c7e14293c26dbff5abe5e4ce4 Mon Sep 17 00:00:00 2001
+From: Vlad Zahorodnii <vlad.zahorodnii@kde.org>
+Date: Tue, 21 Mar 2023 20:31:44 +0200
+Subject: [PATCH] Drop unused kitemviews dependency
+
+Seems unused. KWin compiles fine without it.
+
+(cherry picked from commit 2c0acdca11dd25b0a3d5de8125c61d3523e83fbd)
+---
+ CMakeLists.txt | 1 -
+ src/kcms/scripts/CMakeLists.txt | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f98937161f..d49f8a9471 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -90,7 +90,6 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+ NewStuff
+ Service
+ XmlGui
+- ItemViews
+ )
+
+ find_package(Threads)
+diff --git a/src/kcms/scripts/CMakeLists.txt b/src/kcms/scripts/CMakeLists.txt
+index 66966d6d46..fd7a368a97 100644
+--- a/src/kcms/scripts/CMakeLists.txt
++++ b/src/kcms/scripts/CMakeLists.txt
+@@ -18,7 +18,6 @@ target_link_libraries(kcm_kwin_scripts
+ KF5::NewStuffWidgets
+ KF5::Package
+ KF5::QuickAddons
+- KF5::ItemViews
+ )
+
+ kpackage_install_package(package kcm_kwin_scripts kcms)
+--
+2.42.0
+
diff --git a/kde-plasma/kwin/files/kwin-5.27.8-crashfix.patch b/kde-plasma/kwin/files/kwin-5.27.8-crashfix.patch
new file mode 100644
index 000000000000..e8d6cca37fee
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-5.27.8-crashfix.patch
@@ -0,0 +1,39 @@
+From f099b206b6d8cffee1b410a51e540d3750c4a0af Mon Sep 17 00:00:00 2001
+From: Xaver Hugl <xaver.hugl@gmail.com>
+Date: Tue, 12 Sep 2023 16:23:15 +0200
+Subject: [PATCH] backends/drm: check activePending instead of active for when
+ applying a new gamma ramp is allowed
+
+The crtc may not be set yet in some cases
+
+BUG: 471562
+(cherry picked from commit 57fae99f33aa5d092ebb82e9924fbd7fbb932fc7)
+---
+ src/backends/drm/drm_output.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/backends/drm/drm_output.cpp b/src/backends/drm/drm_output.cpp
+index 558de1f7c4b..c55c4c1832f 100644
+--- a/src/backends/drm/drm_output.cpp
++++ b/src/backends/drm/drm_output.cpp
+@@ -466,7 +466,7 @@ DrmOutputLayer *DrmOutput::primaryLayer() const
+
+ bool DrmOutput::setGammaRamp(const std::shared_ptr<ColorTransformation> &transformation)
+ {
+- if (!m_pipeline->active()) {
++ if (!m_pipeline->activePending()) {
+ return false;
+ }
+ m_pipeline->setGammaRamp(transformation);
+@@ -483,7 +483,7 @@ bool DrmOutput::setGammaRamp(const std::shared_ptr<ColorTransformation> &transfo
+
+ bool DrmOutput::setCTM(const QMatrix3x3 &ctm)
+ {
+- if (!m_pipeline->active()) {
++ if (!m_pipeline->activePending()) {
+ return false;
+ }
+ m_pipeline->setCTM(ctm);
+--
+GitLab
+