summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-01 16:47:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-01 16:47:54 +0100
commitc545c34c9943252735b3bca1a9542db7f56cb9cb (patch)
treec93d13171a016c5e839c08e9a5cd04ed0036341b /kde-plasma/layer-shell-qt
parent958e1f729da918df0d3a435745d914882c2786e5 (diff)
gentoo auto-resync : 01:08:2023 - 16:47:53
Diffstat (limited to 'kde-plasma/layer-shell-qt')
-rw-r--r--kde-plasma/layer-shell-qt/Manifest2
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-5.27.7.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/Manifest b/kde-plasma/layer-shell-qt/Manifest
index 9db85f5618fb..fa6da91e0c55 100644
--- a/kde-plasma/layer-shell-qt/Manifest
+++ b/kde-plasma/layer-shell-qt/Manifest
@@ -1,3 +1,5 @@
DIST layer-shell-qt-5.27.6.tar.xz 18456 BLAKE2B 89d60ce8e316e2fc3fbf3326d478b6db580cfd874f3e39f42c8ad95b2f5932c885a9c1a1b7334d870ec35846459ff9fce91cabee4980704e08d657f89d954bb4 SHA512 1c11f580ac00286873d194968196cb3d9a4660a1c693592846f6e59c61f2199600314b72ca94c681750f62e1a911f04caee8419d26f9a6af5f88f37872c6686d
+DIST layer-shell-qt-5.27.7.tar.xz 18452 BLAKE2B 37944799382767e444621f3fba9e4094c186a525cbe7b7f2c25ada07346d5a6074c2cc2ff4ed3553ad50cc9db197c4ab505bca063cfd353308e51fc710487d47 SHA512 3f03f9850a95b05c6f6c194552127feb0af7830e705eb5d8497b0793f6d1165d2e73ba99657aea3f312d98dca57f98b7d3a359c09d8afda68fa5fe02619287aa
EBUILD layer-shell-qt-5.27.6.ebuild 827 BLAKE2B 31c7b8a1a3d553ed9f486dd0c06fb5715e88ccc020248bcbefd8503c84b4271a695db6e5fe27aedbdd33e5367586875b3a3b2b0be9e5d276cdd0c6ad9dee3043 SHA512 b3cc997dee6ab74cba37f6d3bcdb58a51d8a16bf60f892a1f2392b972b74063a481c8fff5da10e8718d67f01c4f538fcb5c9f47ccc8bd3d5b2d42c63424fc6c7
+EBUILD layer-shell-qt-5.27.7.ebuild 830 BLAKE2B ce6df7c80e24b8033559a190728d7f7b56581bb38e4211e9e38cde52a81eea4acb5efe7c743b3d96bd9fae736cce193430360bdc0ba82d2e751aaeb8f03ce18b SHA512 704907fb869aacfffe527c5f4318b5ab7e68bf8a93b79325912c4e1902d1e2a7a861c76d22799707b36b63d8d8530e0364676b48913527adbfc1daf035180827
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-5.27.7.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-5.27.7.ebuild
new file mode 100644
index 000000000000..8e499271aa76
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-5.27.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"