summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-firewall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /kde-plasma/plasma-firewall
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest2
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-5.23.5.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
index 4d3c7a79a87b..5d94b553a2ad 100644
--- a/kde-plasma/plasma-firewall/Manifest
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -1,3 +1,5 @@
DIST plasma-firewall-5.23.4.tar.xz 344036 BLAKE2B f4ba093bb21680f76bbb7040b6bdb25c122d38574b1e117fb9966b860d8d68ca19725f2c8656bf187afdea609c1e302b03b876bb4f02d2fe3c8383eb5b626f35 SHA512 2628ce262138e5f7526556d788169e32bb143ca4f63b6dc2fee222ec1772835a6d311e24eb01de73c2fdff52319b74c857990acfe3e960f7025d2c05a3baeac5
+DIST plasma-firewall-5.23.5.tar.xz 344132 BLAKE2B 3277329f223f5b4afe33bcf663b8c9f999a8dda4cab593e04d57fb8b2d6d4d899f76f803ca6cc8e3ef718bbcb09f2cb6d24dbaa1c3abcbfa5e163dd791f066ca SHA512 c18b25ad85f57da80edfc03cd445d317162ad2f952fe7ecd09f43af274798acd965de0f8643a636bee74e3572f0ab66f3db876126009b9c98f486a1cfe0e386e
EBUILD plasma-firewall-5.23.4.ebuild 1591 BLAKE2B 07629ef380960625473cb90f961300f9ef17ec3e24cb8fd9a8ca8495d1d2d2e7632676a132c9fa2eb52c1707c8e9776b474ae3b73d623809218db94da68bc018 SHA512 4a13fef5d2a4daf31a09ce0185d280cd2f24a48f7e9928ae3962954ac86dde1dae5f8381f89db0aa8a0465e521cfbcc49811610790a127d51c8da6e56c2e932c
+EBUILD plasma-firewall-5.23.5.ebuild 1594 BLAKE2B d6ce450a42915ddf7a24d36d030db6883e6a3d6d06020b6377a8c903d82519899fd83466f871b4b11aa3bd9b0ef1f4fc391d6bdb65a7c1f779336ebd2d94e23a SHA512 8a69f4a8bf6a1860b5317a0a6e0571233cf2142dbea2a9dd101572f24a459c4754d914f44f2d27954ea1be3a75f5f8b4cfb84d47bfc2fa95a58e2d7854bc0175
MISC metadata.xml 481 BLAKE2B dccce364cb3100483c9d5932a250f05575badc6c66a0868a706817c3da4be16fabfdc584fea5d6fe45284da282b2123b1b7985e7813264d27a0338dcb76428ec SHA512 f3925caf241daf159b2b19ea70c4a177f023487ba3fef866e7fc529563b045664debaafb0a9978d05882b69457d9dada314c3109803eaf2e8bb244ac5f9b8f3d
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-5.23.5.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-5.23.5.ebuild
new file mode 100644
index 000000000000..5b21913225e9
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-5.23.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+KFMIN=5.86.0
+QTMIN=5.15.2
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}