summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /kde-plasma/plasma-integration
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest2
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.15.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 92c0c2033aef..c5089e4e58eb 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,5 @@
DIST plasma-integration-5.14.5.tar.xz 54192 BLAKE2B f032456177475eb9db60dd8d1499693dbd35480df3e2150e1a073da82a41d934459d52620ac4ff7cc52d64473b38da3ab2e66b433ab89be18d746014d6936153 SHA512 6169066cf8afc96f7a595a0ac1c54785ea8f7cfbd609d30b8aa8a12586256575746318765c92038c18ab976ee064a190b1131f01f4c336e13d71a1cdfa719429
+DIST plasma-integration-5.15.0.tar.xz 55188 BLAKE2B 83013827b466288b736c4fdf60251aa799bce01c4b0bac1f5e4c5883eca3cc3cb314d4e14edf557136707a641ec60149a099f04abff346cfe7e206da173e3fc2 SHA512 495d3cfe016cfd7b1fb69c4bba71883c7e85ef272bfc68727c65f7daa1ecd148950173b63791a62b4855b718482209a348fb020150e728cde15a07922102ba9a
EBUILD plasma-integration-5.14.5.ebuild 1059 BLAKE2B 3652c87bf431fbe33b22ecfca96de227f1a36f74f6d780c6f1257cf5b5c06819b8f2288e62942868062b798d5b6f7ad4c0773fc614ed0a3e686ebc36c90e1817 SHA512 5f52fd6913ba99692cda205c313ac2b891036c0479aa4e0cd6fa809cee5ac3da79b7f123cdb23a9ca1daaa38890649f3c5733f3c2b10270e07f5856d9d6cf118
+EBUILD plasma-integration-5.15.0.ebuild 1061 BLAKE2B de6dba39b5478dfc17cfc75db01423227c38493b7121db0bc60eadbb32ef618ed4e465ad373b86e5e418db261e53f9b634e7b56c6e2e2ac3b8ea99f6fa6ff831 SHA512 acae6a3285cfb9813155eea32abb7593fcf80b547405de1e4603c7509df0078877df4e00c4d7aaceb74bcaba6b6df073214591e99328fc3cabcbb36714fa5bf2
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.15.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.15.0.ebuild
new file mode 100644
index 000000000000..b28163426a43
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.15.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"