summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-13 00:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-13 00:12:52 +0000
commit965058196f44550f3bc491dd85064071e085b776 (patch)
tree8485c648f0ac19b27204c8b331c3619c93463cce /kde-plasma/plasma-integration
parent0ec1e1dd7867c3dedcbea76c9b6e847d6b388c03 (diff)
gentoo auto-resync : 13:02:2025 - 00:12:52
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest2
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-6.3.0.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index c3078e025c0d..98f6fc1b6042 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,5 @@
DIST plasma-integration-6.2.5.tar.xz 96116 BLAKE2B 96c14b2422bf54f94cb23f62388ccc961d1a6284111c297049ed2ea6d4793e0f15d807ee14826a066ae1cdbbbe70824057edee7c534dca5072251b1e554daa6e SHA512 fcb25f357fb5cad41dccfcbdd4a452fca64a87a8a2c67d1e738a771d0de7fc36bf1c7b74f846e7f40bb85fd84cfd213d9c5c8cf4f0cc4f3737d5c89852934c42
+DIST plasma-integration-6.3.0.tar.xz 96832 BLAKE2B 3aad46889fc272fbc9c61ea81da1fb41e01c2f8c8e0ba755e61731561c465975405d859224f3f91bb21176e0634e332a94393868c0e045dd479f78cb10fdb19d SHA512 f2a130f56028a89801c90b93af9549c22a46635b60325840c44cfdbeb10da7979293a0b44107c036f5b6117eb5cd0fbd81455140b7c1be82339cb4adbedb6957
EBUILD plasma-integration-6.2.5.ebuild 2363 BLAKE2B aaedfd89382b5aee0d3c8c28f2f8f8b4af032bb9862e8cdcba0eb2e2da2c7ee688588c2ca878db4973b683bc87edce69c81087f912409c462b1971e303596997 SHA512 0e914514bf4a917b12ddc79e8e8aeb6c1faca1a5772e7bd0979c7cfdb80fd0a8d5d93d137159a880f93c185dfe40da8558d6cdb396a714b69de84301e7b1cff9
+EBUILD plasma-integration-6.3.0.ebuild 2370 BLAKE2B 47f7317bd17ac7322c3c28d6c4443faae9960dff492d2582b3a34db2c5fd534751c06a1a5ea6dbc74c2cf66f9b3585a1422bd7f1f4d4790c6a3f6abcc7661be0 SHA512 c4ecc551ea571b7344719bb3dc747570d9638f7677a310d28e9f149051f581933bc75b4ef54d2346860e15d9c86d3bb1ebaf57b0b9dff9936de7b38c65282cce
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/plasma-integration/plasma-integration-6.3.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-6.3.0.ebuild
new file mode 100644
index 000000000000..bda8e30ebe96
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-6.3.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KF5MIN=5.115.0
+KFMIN=6.10.0
+QT5MIN=5.15.12
+QTMIN=6.8.1
+inherit ecm plasma.kde.org xdg
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="qt5"
+
+# requires running kde environment
+RESTRICT="test"
+
+# slot ops: qdbus*_p.h and Qt6::GuiPrivate for qtx11extras_p.h
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=kde-frameworks/kcolorscheme-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ x11-libs/libXcursor
+ x11-libs/libxcb
+ qt5? (
+ >=dev-qt/qtdbus-${QT5MIN}:5
+ >=dev-qt/qtgui-${QT5MIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QT5MIN}:5
+ >=dev-qt/qtwayland-${QT5MIN}:5
+ >=dev-qt/qtwidgets-${QT5MIN}:5
+ >=dev-qt/qtx11extras-${QT5MIN}:5
+ >=kde-frameworks/kcompletion-${KF5MIN}:5
+ >=kde-frameworks/kconfig-${KF5MIN}:5
+ >=kde-frameworks/kconfigwidgets-${KF5MIN}:5
+ >=kde-frameworks/kcoreaddons-${KF5MIN}:5
+ >=kde-frameworks/kguiaddons-${KF5MIN}:5
+ >=kde-frameworks/ki18n-${KF5MIN}:5
+ >=kde-frameworks/kiconthemes-${KF5MIN}:5
+ >=kde-frameworks/kio-${KF5MIN}:5
+ >=kde-frameworks/kjobwidgets-${KF5MIN}:5
+ >=kde-frameworks/knotifications-${KF5MIN}:5
+ >=kde-frameworks/kwindowsystem-${KF5MIN}:5
+ >=kde-frameworks/kxmlgui-${KF5MIN}:5
+ >=kde-plasma/kwayland-${KF5MIN}:5
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.16.0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+ media-fonts/noto-emoji
+"
+PDEPEND="
+ >=kde-plasma/xdg-desktop-portal-kde-${KDE_CATV}:6
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ qt5? ( >=dev-qt/qtwaylandscanner-${QT5MIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_QT6=ON
+ -DBUILD_QT5=$(usex qt5)
+ )
+ ecm_src_configure
+}