summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-11 19:38:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-11 19:38:57 +0100
commitc650f7cf611feaa59620fd8626e78108fa3b5e51 (patch)
tree31eba3ef4db85c7cef7cfb89ee87c81e732928a9 /kde-plasma/plasma-integration
parent59970d0b9cd0a564851f255aebb29a9f76e39c19 (diff)
gentoo auto-resync : 11:10:2022 - 19:38:57
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest2
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.26.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index ba933e7146ab..c9ca3f2fcd23 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,5 @@
DIST plasma-integration-5.25.5.tar.xz 86432 BLAKE2B dbd06f375ee4b852a35337f8137ee37e64433bf458e076c17538131d3b5746d872eae57ebb45b69a99af2f8b24c2901be9ce17ede079dd69bfba966844f0f956 SHA512 8595ce9026dbd2943c6579611a06889c2d41e6a2433837809d91b430d4b683931df065b9f681e8857f1a56d98d7703769d97a903056d0fe06bf1ed29986b26e9
+DIST plasma-integration-5.26.0.tar.xz 88916 BLAKE2B 4d008336f5655234a0ec0f958c365b8351aaf6729328cd2f5a0b77139ce459105b34dd7fff81c57508e72551d0217ac60161c9473d2a82e9343dd00a35f783ec SHA512 c1b74368eee3a41ddc58caf9202e6ab00e032b91d976951cf64706d56c58031a3be43d95419a611c5624cec872389c68d8b5e2fc7c2c4bccb5481180de8b0e5f
EBUILD plasma-integration-5.25.5.ebuild 1399 BLAKE2B b43877ce24a1f53e5491bd461d5afd78908cf2fcd04e2b233cda6bb9ac2e9b096b2129f7023ea3aad8649e6b5ce9b35e277ef1da9b21ceb996ffd021ec5ff128 SHA512 1fef84956d038fa56f59ac4fb59ec87e18869940cddbbd82b30fd863b029dd69ddf5f7048bfb488d8c1506c8acce78e8c16a8910b0bf584ed4c0ef922c4fe413
+EBUILD plasma-integration-5.26.0.ebuild 1364 BLAKE2B 70d9d6b62dc9b13a3f759ab6fffc0db9eed8953dccffbc6c47b34b14d899b7954a9d96fd86d0919175bd6f5e319305a0b83babd6431de686ca733dfc3d686cea SHA512 c81e5d88353406ad397e6fe79120e25f3530c08539ad75e051d46fdbf7204929f240893d4bc46bc9ce9346044b118b75111113ebc3f3bd7eae79c2a2540d72a7
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.26.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.26.0.ebuild
new file mode 100644
index 000000000000..cd11319277fc
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.26.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# requires running kde environment
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.6.0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+"