summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-meta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-13 00:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-13 00:12:52 +0000
commit965058196f44550f3bc491dd85064071e085b776 (patch)
tree8485c648f0ac19b27204c8b331c3619c93463cce /kde-plasma/plasma-meta
parent0ec1e1dd7867c3dedcbea76c9b6e847d6b388c03 (diff)
gentoo auto-resync : 13:02:2025 - 00:12:52
Diffstat (limited to 'kde-plasma/plasma-meta')
-rw-r--r--kde-plasma/plasma-meta/Manifest1
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-6.3.0.ebuild151
2 files changed, 152 insertions, 0 deletions
diff --git a/kde-plasma/plasma-meta/Manifest b/kde-plasma/plasma-meta/Manifest
index 60243fb0eb65..2c8b3cc8e754 100644
--- a/kde-plasma/plasma-meta/Manifest
+++ b/kde-plasma/plasma-meta/Manifest
@@ -1,2 +1,3 @@
EBUILD plasma-meta-6.2.5.ebuild 5548 BLAKE2B e58b0af93ab62c79846cbd2ca6d4d4391c3a6228c96a4036f037a32b1a51941a3ad475f1d4a9593e6597d31c9716ae30a296de6bd14ace8c5d92ee969b8d9562 SHA512 e6f03a8a59325e26579daff788e6317a854630e9bdd2c4f1e118acf57208528b51e8b38b91b9defa6494948e70f99feb4d59e14fc946a656d905333d15cf56fb
+EBUILD plasma-meta-6.3.0.ebuild 5550 BLAKE2B c80d12662f02d9e4484328b11ba6f3b5307a99ec6542dce99fa985351d26c98cc51bdce597ab99188f5b927b116be8bfa4922de5aea7b9030d92e43aba849a00 SHA512 2ce708a2859b79922e9d6f12e1a7f7d6e9c8b7508307d4329e55077549ab2350f98db70188b27f5fbdacf2ed0e00ef9534288ba741d6a8a0e20df5faabad4056
MISC metadata.xml 2824 BLAKE2B 505cc4fe402e3bade5a67c5536c3394166767563d696c2acc026437cfa1a527269e137cfec8edcfb70f73c08149d3cc25ff9847e30e5e999f1d65b282e33bd2b SHA512 302cf58eb160ef91f2d05da23621ac1c0e0fc69c0c92a93510b6388e9427d345c52f14328fbd557f6a02d8c6966a008e6c7dad3994e7f0e07eddddfdd8c2e456
diff --git a/kde-plasma/plasma-meta/plasma-meta-6.3.0.ebuild b/kde-plasma/plasma-meta/plasma-meta-6.3.0.ebuild
new file mode 100644
index 000000000000..42f318fe4663
--- /dev/null
+++ b/kde-plasma/plasma-meta/plasma-meta-6.3.0.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Merge this to pull in all Plasma 6 packages"
+HOMEPAGE="https://kde.org/plasma-desktop/"
+
+LICENSE="metapackage"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="accessibility bluetooth +browser-integration colord +crash-handler crypt
+cups discover +display-manager +elogind +firewall flatpak grub gtk +kwallet
++networkmanager oxygen-theme plymouth pulseaudio qt5 rdp +sddm sdk +smart systemd
+thunderbolt unsupported wacom +wallpapers webengine +xwayland"
+
+REQUIRED_USE="^^ ( elogind systemd )"
+
+RDEPEND="
+ !${CATEGORY}/${PN}:5
+ !kde-plasma/khotkeys:5
+ >=kde-plasma/breeze-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/kactivitymanagerd-${PV}:${SLOT}
+ >=kde-plasma/kde-cli-tools-${PV}:${SLOT}
+ >=kde-plasma/kde-cli-tools-common-${PV}
+ >=kde-plasma/kdecoration-${PV}:${SLOT}
+ >=kde-plasma/kdeplasma-addons-${PV}:${SLOT}
+ >=kde-plasma/kdesu-gui-${PV}
+ >=kde-plasma/keditfiletype-${PV}
+ >=kde-plasma/kgamma-${PV}:${SLOT}
+ >=kde-plasma/kglobalacceld-${PV}:${SLOT}
+ >=kde-plasma/kinfocenter-${PV}:${SLOT}
+ >=kde-plasma/kmenuedit-${PV}:${SLOT}
+ >=kde-plasma/kpipewire-${PV}:${SLOT}
+ >=kde-plasma/kscreen-${PV}:${SLOT}
+ >=kde-plasma/kscreenlocker-${PV}:${SLOT}
+ >=kde-plasma/ksshaskpass-${PV}:${SLOT}
+ >=kde-plasma/ksystemstats-${PV}:${SLOT}
+ >=kde-plasma/kwayland-${PV}:${SLOT}
+ >=kde-plasma/kwin-${PV}:${SLOT}[lock]
+ >=kde-plasma/kwrited-${PV}:${SLOT}
+ >=kde-plasma/layer-shell-qt-${PV}:${SLOT}
+ >=kde-plasma/libkscreen-${PV}:${SLOT}
+ >=kde-plasma/libksysguard-${PV}:${SLOT}
+ >=kde-plasma/libplasma-${PV}:${SLOT}
+ >=kde-plasma/milou-${PV}:${SLOT}
+ >=kde-plasma/ocean-sound-theme-${PV}:${SLOT}
+ >=kde-plasma/plasma-activities-${PV}:${SLOT}
+ >=kde-plasma/plasma-activities-stats-${PV}:${SLOT}
+ >=kde-plasma/plasma-desktop-${PV}:${SLOT}
+ >=kde-plasma/plasma-integration-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/plasma-login-sessions-${PV}:${SLOT}
+ >=kde-plasma/plasma-systemmonitor-${PV}:${SLOT}
+ >=kde-plasma/plasma-welcome-${PV}:${SLOT}
+ >=kde-plasma/plasma-workspace-${PV}:${SLOT}
+ >=kde-plasma/plasma5support-${PV}:${SLOT}
+ >=kde-plasma/polkit-kde-agent-${PV}:*
+ >=kde-plasma/powerdevil-${PV}:${SLOT}
+ >=kde-plasma/qqc2-breeze-style-${PV}:${SLOT}
+ >=kde-plasma/systemsettings-${PV}:${SLOT}
+ >=kde-plasma/xdg-desktop-portal-kde-${PV}:${SLOT}
+ sys-apps/dbus[elogind?,systemd?]
+ sys-auth/polkit[systemd?]
+ sys-fs/udisks:2[elogind?,systemd?]
+ bluetooth? ( >=kde-plasma/bluedevil-${PV}:${SLOT} )
+ browser-integration? ( >=kde-plasma/plasma-browser-integration-${PV}:${SLOT} )
+ colord? ( x11-misc/colord )
+ crash-handler? ( >=kde-plasma/drkonqi-${PV}:${SLOT} )
+ crypt? ( >=kde-plasma/plasma-vault-${PV}:${SLOT} )
+ cups? (
+ >=kde-plasma/print-manager-${PV}:${SLOT}
+ net-print/cups-meta
+ )
+ discover? ( >=kde-plasma/discover-${PV}:${SLOT} )
+ display-manager? (
+ sddm? (
+ >=kde-plasma/sddm-kcm-${PV}:${SLOT}
+ >=x11-misc/sddm-0.21.0_p20240302[elogind?,systemd?]
+ )
+ !sddm? ( x11-misc/lightdm )
+ )
+ elogind? ( sys-auth/elogind[pam] )
+ flatpak? ( >=kde-plasma/flatpak-kcm-${PV}:${SLOT} )
+ grub? ( >=kde-plasma/breeze-grub-${PV}:${SLOT} )
+ gtk? (
+ >=kde-plasma/breeze-gtk-${PV}:${SLOT}
+ >=kde-plasma/kde-gtk-config-${PV}:${SLOT}
+ sys-apps/xdg-desktop-portal-gtk
+ x11-misc/appmenu-gtk-module
+ )
+ kwallet? ( >=kde-plasma/kwallet-pam-${PV}:${SLOT} )
+ networkmanager? (
+ >=kde-plasma/plasma-nm-${PV}:${SLOT}
+ net-misc/networkmanager[elogind?,systemd?]
+ )
+ oxygen-theme? (
+ >=kde-frameworks/oxygen-icons-6.0.0:*
+ >=kde-plasma/oxygen-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/oxygen-sounds-${PV}:${SLOT}
+ )
+ plymouth? (
+ >=kde-plasma/breeze-plymouth-${PV}:${SLOT}
+ >=kde-plasma/plymouth-kcm-${PV}:${SLOT}
+ )
+ pulseaudio? ( >=kde-plasma/plasma-pa-${PV}:${SLOT} )
+ qt5? ( >=kde-plasma/kwayland-integration-${PV}:5 )
+ rdp? ( >=kde-plasma/krdp-${PV}:${SLOT} )
+ sdk? ( >=kde-plasma/plasma-sdk-${PV}:${SLOT} )
+ smart? ( >=kde-plasma/plasma-disks-${PV}:${SLOT} )
+ systemd? (
+ sys-apps/systemd[pam]
+ firewall? ( >=kde-plasma/plasma-firewall-${PV}:${SLOT} )
+ )
+ thunderbolt? ( >=kde-plasma/plasma-thunderbolt-${PV}:${SLOT} )
+ !unsupported? (
+ !gui-apps/qt6ct
+ )
+ wacom? ( >=kde-plasma/wacomtablet-${PV}:${SLOT} )
+ wallpapers? ( >=kde-plasma/plasma-workspace-wallpapers-${PV}:${SLOT} )
+ webengine? ( kde-apps/khelpcenter:6 )
+ xwayland? ( >=gui-apps/xwaylandvideobridge-0.4.0 )
+"
+# Optional runtime deps: kde-plasma/plasma-desktop
+RDEPEND="${RDEPEND}
+ accessibility? ( app-accessibility/orca )
+"
+
+pkg_postinst() {
+ if [[ $(tc-get-cxx-stdlib) == "libc++" ]] ; then
+ # Workaround for bug #923292 (KDE-bug 479679)
+ ewarn "plasmashell and other KDE Plasma components are known to misbehave"
+ ewarn "when built with sys-libs/libcxx, e.g. crashing when right-clicking"
+ ewarn "on a panel. See bug #923292."
+ ewarn ""
+ ewarn "A possible (no warranty!) workaround is building sys-libs/libcxx and"
+ ewarn "sys-libs/libcxxabi with the following in package.env:"
+ ewarn " MYCMAKEARGS=\"-DLIBCXX_TYPEINFO_COMPARISON_IMPLEMENTATION=2\""
+ ewarn "You may then need to rebuild dev-qt/* and kde-*/*."
+ fi
+
+ if ! use qt5 && has_version dev-qt/qtgui; then
+ ewarn "KF5- and Qt5-based applications will exhibit various integration bugs"
+ ewarn "and generally look out of place in Plasma 6 without the dependencies"
+ ewarn "enforced by kde-plasma/plasma-meta[qt5]."
+ ewarn
+ ewarn "This warning message is being displayed because dev-qt/qtgui:5 is"
+ ewarn "currently installed which indicates the use of such applications."
+ fi
+}