summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-meta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-26 00:12:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-26 00:12:24 +0100
commit9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (patch)
tree2d53ee03e360a9c66a5d8dd8986eee286514336b /kde-plasma/plasma-meta
parent996a2bda06cb164877d5d952774a6db1b271c2f3 (diff)
gentoo auto-resync : 26:06:2024 - 00:12:24
Diffstat (limited to 'kde-plasma/plasma-meta')
-rw-r--r--kde-plasma/plasma-meta/Manifest1
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-6.1.1.ebuild142
2 files changed, 143 insertions, 0 deletions
diff --git a/kde-plasma/plasma-meta/Manifest b/kde-plasma/plasma-meta/Manifest
index 7c0dfe2b16b6..3f365ddcda4b 100644
--- a/kde-plasma/plasma-meta/Manifest
+++ b/kde-plasma/plasma-meta/Manifest
@@ -1,3 +1,4 @@
EBUILD plasma-meta-5.27.11-r1.ebuild 4212 BLAKE2B c1db8c8defe4a168fa0b195635907ba3b6e257db3fe2d4cb82e4808ff1dacb28428b41a36812c8dc0579decef2ca0e499f8ef3fec17e14b802988248e005f3e4 SHA512 79e1eca7478ca7d873e9d16532f8b602b9accad10360922bcf09846f388e21df702254ccafb9e0c42a2f662dedc4177f01602bd6e4889a2a6a555edb28c1e735
EBUILD plasma-meta-6.1.0.ebuild 5255 BLAKE2B 52533730a35df32c0529a2f350b4c6c137d3dc1d3ea231e25aa19ff1e50bb50160bfc543e14197cb4425fee83c425ad9afba987633fca23aa27248532191ebeb SHA512 884130308313d1ba7497ebdc0e9d7f4600024611359eed817408414a1adcb97c0e5ca7d5c74b51a5f8966b35c9920791f29e23ac4171c6754dfd0126b21858d6
+EBUILD plasma-meta-6.1.1.ebuild 5279 BLAKE2B 42425752ff3b4ef2a9e00a103ef3d76b1a8e42d0872f35f32e78e3f00ce4cf5ebe1d36280eab30b4bb1c9ad2e6565e24443ed6c80f0fc992da1ee6b5d4e2b11c SHA512 de5a31b65515a5c6afb766b4b2f4ec1c7b2ecf6b24ec289e9aee04b83a1237435a4c94fbb17428cb70bb16e38d535bdc1434d5d9ebf428968a994529d9ce4424
MISC metadata.xml 3059 BLAKE2B d3e3485ebb608a603d13f0263533dd97d04ed0f9e9610ee429808f521770a92e59f9fea4992c8d280139cfbe5468029af073813d8195745c7182ae56a95e5d2a SHA512 0576008409be1377c1ac443aad3d039a525e62aba4b7fc93230869a0054640abea0ba40ea69aa3013a8ec7ad48e0c35ba312468626fee5662b41ccaaf86ceb63
diff --git a/kde-plasma/plasma-meta/plasma-meta-6.1.1.ebuild b/kde-plasma/plasma-meta/plasma-meta-6.1.1.ebuild
new file mode 100644
index 000000000000..13e81b8220c3
--- /dev/null
+++ b/kde-plasma/plasma-meta/plasma-meta-6.1.1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Merge this to pull in all Plasma 6 packages"
+HOMEPAGE="https://kde.org/plasma-desktop/"
+
+LICENSE="metapackage"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="accessibility bluetooth +browser-integration colord +crash-handler crypt
+cups discover +display-manager +elogind +firewall flatpak grub gtk +kwallet
++networkmanager oxygen-theme plymouth pulseaudio qt5 rdp +sddm sdk +smart systemd
+thunderbolt unsupported wacom +wallpapers webengine +xwayland"
+
+REQUIRED_USE="^^ ( elogind systemd )"
+
+RDEPEND="
+ !${CATEGORY}/${PN}:5
+ >=kde-plasma/breeze-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/kactivitymanagerd-${PV}:${SLOT}
+ >=kde-plasma/kde-cli-tools-${PV}:${SLOT}
+ >=kde-plasma/kdecoration-${PV}:${SLOT}
+ >=kde-plasma/kdeplasma-addons-${PV}:${SLOT}
+ >=kde-plasma/kgamma-${PV}:${SLOT}
+ >=kde-plasma/kglobalacceld-${PV}:${SLOT}
+ >=kde-plasma/kinfocenter-${PV}:${SLOT}
+ >=kde-plasma/kmenuedit-${PV}:${SLOT}
+ >=kde-plasma/kpipewire-${PV}:${SLOT}
+ >=kde-plasma/kscreen-${PV}:${SLOT}
+ >=kde-plasma/kscreenlocker-${PV}:${SLOT}
+ >=kde-plasma/ksshaskpass-${PV}:${SLOT}
+ >=kde-plasma/ksystemstats-${PV}:${SLOT}
+ >=kde-plasma/kwayland-${PV}:${SLOT}
+ >=kde-plasma/kwin-${PV}:${SLOT}[lock]
+ >=kde-plasma/kwrited-${PV}:${SLOT}
+ >=kde-plasma/layer-shell-qt-${PV}:${SLOT}
+ >=kde-plasma/libkscreen-${PV}:${SLOT}
+ >=kde-plasma/libksysguard-${PV}:${SLOT}
+ >=kde-plasma/libplasma-${PV}:${SLOT}
+ >=kde-plasma/milou-${PV}:${SLOT}
+ >=kde-plasma/ocean-sound-theme-${PV}:${SLOT}
+ >=kde-plasma/plasma-activities-${PV}:${SLOT}
+ >=kde-plasma/plasma-activities-stats-${PV}:${SLOT}
+ >=kde-plasma/plasma-desktop-${PV}:${SLOT}
+ >=kde-plasma/plasma-integration-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/plasma-systemmonitor-${PV}:${SLOT}
+ >=kde-plasma/plasma-welcome-${PV}:${SLOT}
+ >=kde-plasma/plasma-workspace-${PV}:${SLOT}
+ >=kde-plasma/plasma5support-${PV}:${SLOT}
+ >=kde-plasma/polkit-kde-agent-${PV}:*
+ >=kde-plasma/powerdevil-${PV}:${SLOT}
+ >=kde-plasma/qqc2-breeze-style-${PV}:${SLOT}
+ >=kde-plasma/systemsettings-${PV}:${SLOT}
+ >=kde-plasma/xdg-desktop-portal-kde-${PV}:${SLOT}
+ sys-apps/dbus[elogind?,systemd?]
+ sys-auth/polkit[systemd?]
+ sys-fs/udisks:2[elogind?,systemd?]
+ bluetooth? ( >=kde-plasma/bluedevil-${PV}:${SLOT} )
+ browser-integration? ( >=kde-plasma/plasma-browser-integration-${PV}:${SLOT} )
+ colord? ( x11-misc/colord )
+ crash-handler? ( >=kde-plasma/drkonqi-${PV}:${SLOT} )
+ crypt? ( >=kde-plasma/plasma-vault-${PV}:${SLOT} )
+ cups? ( >=kde-plasma/print-manager-${PV}:${SLOT} )
+ discover? ( >=kde-plasma/discover-${PV}:${SLOT} )
+ display-manager? (
+ sddm? (
+ >=kde-plasma/sddm-kcm-${PV}:${SLOT}
+ >=x11-misc/sddm-0.21.0_p20240302[elogind?,systemd?]
+ )
+ !sddm? ( x11-misc/lightdm )
+ )
+ elogind? ( sys-auth/elogind[pam] )
+ flatpak? ( >=kde-plasma/flatpak-kcm-${PV}:${SLOT} )
+ grub? ( >=kde-plasma/breeze-grub-${PV}:${SLOT} )
+ gtk? (
+ >=kde-plasma/breeze-gtk-${PV}:${SLOT}
+ >=kde-plasma/kde-gtk-config-${PV}:${SLOT}
+ x11-misc/appmenu-gtk-module
+ )
+ kwallet? ( >=kde-plasma/kwallet-pam-${PV}:${SLOT} )
+ networkmanager? (
+ >=kde-plasma/plasma-nm-${PV}:${SLOT}
+ net-misc/networkmanager[elogind?,systemd?]
+ )
+ oxygen-theme? (
+ >=kde-frameworks/oxygen-icons-6.0.0:*
+ >=kde-plasma/oxygen-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/oxygen-sounds-${PV}:${SLOT}
+ )
+ plymouth? (
+ >=kde-plasma/breeze-plymouth-${PV}:${SLOT}
+ >=kde-plasma/plymouth-kcm-${PV}:${SLOT}
+ )
+ pulseaudio? ( >=kde-plasma/plasma-pa-${PV}:${SLOT} )
+ qt5? ( >=kde-plasma/kwayland-integration-${PV}:5 )
+ rdp? ( >=kde-plasma/krdp-${PV}:${SLOT} )
+ sdk? ( >=kde-plasma/plasma-sdk-${PV}:${SLOT} )
+ smart? ( >=kde-plasma/plasma-disks-${PV}:${SLOT} )
+ systemd? (
+ sys-apps/systemd[pam]
+ firewall? ( >=kde-plasma/plasma-firewall-${PV}:${SLOT} )
+ )
+ thunderbolt? ( >=kde-plasma/plasma-thunderbolt-${PV}:${SLOT} )
+ !unsupported? (
+ !gui-apps/qt6ct
+ )
+ wacom? ( >=kde-plasma/wacomtablet-${PV}:${SLOT} )
+ wallpapers? ( >=kde-plasma/plasma-workspace-wallpapers-${PV}:${SLOT} )
+ webengine? ( kde-apps/khelpcenter:6 )
+ xwayland? ( >=gui-apps/xwaylandvideobridge-0.4.0 )
+"
+# Optional runtime deps: kde-plasma/plasma-desktop
+RDEPEND="${RDEPEND}
+ accessibility? ( app-accessibility/orca )
+"
+
+pkg_postinst() {
+ if [[ $(tc-get-cxx-stdlib) == "libc++" ]] ; then
+ # Workaround for bug #923292 (KDE-bug 479679)
+ ewarn "plasmashell and other KDE Plasma components are known to misbehave"
+ ewarn "when built with sys-libs/libcxx, e.g. crashing when right-clicking"
+ ewarn "on a panel. See bug #923292."
+ ewarn ""
+ ewarn "A possible (no warranty!) workaround is building sys-libs/libcxx and"
+ ewarn "sys-libs/libcxxabi with the following in package.env:"
+ ewarn " MYCMAKEARGS=\"-DLIBCXX_TYPEINFO_COMPARISON_IMPLEMENTATION=2\""
+ ewarn "You may then need to rebuild dev-qt/* and kde-*/*."
+ fi
+
+ if ! use qt5 && has_version dev-qt/qtgui; then
+ ewarn "KF5- and Qt5-based applications will exhibit various integration bugs"
+ ewarn "and generally look out of place in Plasma 6 without the dependencies"
+ ewarn "enforced by kde-plasma/plasma-meta[qt5]."
+ ewarn
+ ewarn "This warning message is being displayed because dev-qt/qtgui:5 is"
+ ewarn "currently installed which indicates the use of such applications."
+ fi
+}