summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-nm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /kde-plasma/plasma-nm
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest2
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.12.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index e230545935f1..f3027ef52afd 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,4 +1,6 @@
AUX plasma-nm-add_EAP-PWD.patch 10213 BLAKE2B e35cf580481f9ddc139fd77d7f3a652440bff749a1c34e26ef579ff1dc9ac741b97d7f6f8ea2165c959febaedd16396e29af3a4adf20bb74b3ec6b73fb77193d SHA512 0db8b7e4c9e7ea51acb6ee7c8f79b1cb1040899b45e02a80f83d268197844e5bcee3b963796e9a70d364677adeff2180d5b4520d529c7603e10d91a9a0f162f7
DIST plasma-nm-5.11.5.tar.xz 718500 BLAKE2B bdd9520cfa3a305f7f2c271fdfc9678b43ed46e160ff7c7485a963889b32e60f56408bcc39b4fce81e570ce194410730a628bb2eb96afcfba8704b787d90c05a SHA512 6bc42e9b385fff03d994d66fb2088ce22b2766588c655466e4e26a0b57f1533c142ce7712c9182d9003368f30086333ea9670bac54b9b797e58a968f8bfc3512
+DIST plasma-nm-5.12.0.tar.xz 701352 BLAKE2B b1c3f620b126f7f8edf7dbeb785c5195bd4c98dae78eca9bbc1f0d05de7f0bec5bcf935ab9a62b0a2579495dc2c07563c696924610052e98b0318205d6ef6e61 SHA512 08b6cc42eee0e5a4314884be34e7108bf6bc96fe5916cd52f85cb9913d3e488cb15b7cb680d87ab8257a54ebb16ea6f3f54e31b927e18e86024c43c1f14de9c0
EBUILD plasma-nm-5.11.5.ebuild 1789 BLAKE2B 7c5af92a13398f943f6277e1b87864a40fd5c2a5ebb1f7765a64309a38e006339c4c0e63192e18180ad1b98143df2ffb4b743c990438f99930406c61b1d362ed SHA512 d376eaf845a52b6e916f554a848dcc767774bb972fde518e10404eda1b269025e4d4108132a64b4dff9d2c7453b88dd47ad5280ac12baef52eb3cc63d89d7618
+EBUILD plasma-nm-5.12.0.ebuild 2046 BLAKE2B 24f4f016ab87efb360cc36d4c8380b809216845381b9f404b790af4d110a5432888d9012ec1ea1e078b70bf780519afbbc7119c9360bd62e01cf1504d2095f3d SHA512 59dcd4c4b8d39e250f7ef08719adc57a25b2592f806a55cdcdd0f17534510814079765dd97a13b0797986231e331131e01c6de23c59e3beef88b8f8fb7f428a1
MISC metadata.xml 479 BLAKE2B 501f2ff581390f3119e9474e1aeafb45f2e13f3cf25650482f39ab38c7fb0e70ac006f269693ef546ef324730f302c454d27d79f0346e43b6f37583ccad1ca93 SHA512 69a8ce09c5a437814562c315dc7ac3142ac6c71906f37a6ea98e7b76fdd332362cfa76e823d0ee1ec920e92c8f7dda2a557071c758e9937886d7df78943b5689
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.12.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.12.0.ebuild
new file mode 100644
index 000000000000..3d76b41d85c4
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.12.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5]
+ >=net-misc/networkmanager-0.9.10.0[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/plasma-nm:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package modemmanager ModemManager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ einfo "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ einfo "However, the networkmanagement KCM can be called from either systemsettings"
+ einfo "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}