summaryrefslogtreecommitdiff
path: root/kde-plasma/xdg-desktop-portal-kde
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /kde-plasma/xdg-desktop-portal-kde
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest2
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.2.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index 03880adc435a..96775be24643 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1,3 +1,5 @@
DIST xdg-desktop-portal-kde-5.16.5.tar.xz 61576 BLAKE2B b9d186e3269aae6c079bae8abf01e790300da5ba255ecaa37ca2b139bb5c017f0cc118adbaca8d4f846cfbf5d563d574cddca4703e9d917f7001468b27734db6 SHA512 381298cc001795902343512f8bb08c363acfb6e3ef398e0f170f305572ca9a5caaf458e85b6f48ac84bcd963a34e535c666b0ddc1bb910a894a8b8de8801467e
+DIST xdg-desktop-portal-kde-5.17.2.tar.xz 62924 BLAKE2B 20fc2265a162c420d99b82dfa8f170af4ad57442a30b60408a5d5dfd65742bb9fb76012afc55b6aba742cf7454fe381a25714991001963d5e4aa1da602f36f84 SHA512 45578698500bb67f3437380bba960204808b257b819c7579e7a0e8ad3d9eefb1244b5709a142b472fa8b0061032137968700d2f9bff5cdf74a97e977c4baa09f
EBUILD xdg-desktop-portal-kde-5.16.5.ebuild 1197 BLAKE2B 8e3e1bc58993f65e68c12eb322d6836b9c9a72ef39169fdb19485ccec9dde8318de54c1a39ad769e27fb157f0fd915b67088b42904e635ecc5128112f0096f69 SHA512 96f8b405ebddad130141e7ef0329911f2d910559b30e13c963d0c89b20e5b4ab8d15b7d325bc9a92f77d1a824a6300fecd006e6ec27700e610fa8930251a170e
+EBUILD xdg-desktop-portal-kde-5.17.2.ebuild 1070 BLAKE2B 7ce44e5998e78c3c8229bf6d518ad5efc00c13b9000a4be6b1522f13d1e865bb27c917426153ad0ab705637d6453a627856d0f98cfcdc3d3274079458648ad99 SHA512 b2a4c1040abfc88e2b57c4d91ca3a3d01577e278753ced74bc02e4cfded5ad6ed9701baf1b1b5fed41afa2bbf4f5f5252d7cbe78a2aec3fef61f27e9a72a8640
MISC metadata.xml 360 BLAKE2B 1e3fae0173fab20df0be6a2bd8432477d2c0ab2b9c4272e72a9d8a9eee3255c56311364ea079d288f87032fbc2ec8cad69f32a6bc41b152d19e307ee84493b49 SHA512 4e7232bd03fad6442491ce16c155b0d447050dfc383bb2c16b51297c8c2dcc2793b6d9ce6703451e9516d5a3017fb9e20e85ed7208c94c0faa4489bcbd897e22
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.2.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.2.ebuild
new file mode 100644
index 000000000000..c388b6f4f5b6
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="screencast"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport 'cups')
+ $(add_qt_dep qtwidgets)
+ screencast? (
+ media-libs/libepoxy
+ media-libs/mesa[gbm]
+ media-video/pipewire:=
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kwayland)
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/xdg-desktop-portal[screencast?]
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package screencast PipeWire)
+ $(cmake-utils_use_find_package screencast GBM)
+ $(cmake-utils_use_find_package screencast Epoxy)
+ )
+ kde5_src_configure
+}