summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /lxqt-base/lxqt-config
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'lxqt-base/lxqt-config')
-rw-r--r--lxqt-base/lxqt-config/Manifest2
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.17.1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-config/Manifest b/lxqt-base/lxqt-config/Manifest
index 2c91f807970f..4a7906e0f1bd 100644
--- a/lxqt-base/lxqt-config/Manifest
+++ b/lxqt-base/lxqt-config/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-config-0.16.1.tar.xz 327652 BLAKE2B b242aeea758b8dc2804c9ebd4abd9a0ab98d92e7e6620646c90a78ca60238ef0e62e823eac3e226fdd05ddc431e271551ecf34281467a9db03fe5195a2f3e293 SHA512 3322611b74a945b2c4aa60a179fc1edabd09e474502f44e7a0319478a09762ff7a11fbb7603aa26ec8ea593514bbcdfc98fb475009d0dfa4d387963fcdef7e03
+DIST lxqt-config-0.17.1.tar.xz 339184 BLAKE2B cdb2852801b4af141213dbe680f5d9ccf4bf3738ee6c39e4df7e7915ee74209d4516d4ca2675176f31b4fa7afc4c3907ac71afe1d2a88ce39d8831dfc62946ad SHA512 2173acd18ffa5aeee9d11bd73955d0475b53a335df7d95523a2297b5ef3f9a8e4e135a290e7a720a227a92c84532a64d9fbc7a811de242dd32f9e70d036d3ca6
EBUILD lxqt-config-0.16.1.ebuild 1469 BLAKE2B 6311864c7526ffaee49963abfc723178f96bf7621f155712a5505a6315061d6f4d941f81e15011906f97ad4049cc4d9ee7b9cf92f2ad17cd89d00da081cd7b08 SHA512 4377185b8fd44354f088f3d337208812647ab7b3045f27e6ddf685b748b2fdaf5222784c1450ede7b1d2af490c8c205d109b9a6c8003b74eeff6b26fd0e7ba45
+EBUILD lxqt-config-0.17.1.ebuild 1448 BLAKE2B 4f0fe830819227aa7413217dd201b764d2c3ee8522578c619ce15d8d30d70956e7306a4f04e793a66a7d277864e2066e52a55892d640c20942d56bc08335d0a2 SHA512 4afa4fa05904af10b4a4374b8e507a06deca0abf8c1197c739ff50d98b4752cac43ec9338eea01dd3311b8452af5602b8268e8fccd3bcbeca0aa909695e9a949
MISC metadata.xml 450 BLAKE2B 6f59cf0984e8e6c625eef75e01275d3d9e0b09fdbc1fc82fffb8611b44654da27da256148350c632673352ebc397f07b4696efad6f1f0d35489468752a4293cb SHA512 9e74d2cdc46c1c7797ac91f141995fbab7e11f4f05bef094e2af89d3cfe7d47d209de3de5726eee2eb45926185803ff7c7f012aad994f1acbc43feca88e798fc
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.17.1.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.17.1.ebuild
new file mode 100644
index 000000000000..7dc8f7f7264c
--- /dev/null
+++ b/lxqt-base/lxqt-config/lxqt-config-0.17.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="LXQt system configuration control center"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
+SLOT="0"
+IUSE="+monitor +touchpad"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-libs/zlib:=
+ x11-apps/setxkbmap
+ x11-libs/libxcb:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ monitor? ( kde-plasma/libkscreen:5= )
+ touchpad? (
+ virtual/libudev
+ x11-drivers/xf86-input-libinput
+ x11-libs/libXext
+ x11-libs/libXi
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MONITOR=$(usex monitor)
+ -DWITH_TOUCHPAD=$(usex touchpad)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}