summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-08 03:03:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-08 03:03:28 +0000
commit2cd9ff612e84f0c1ef63c9e9e13be53fe576cc2b (patch)
tree6e975e18646dac9f4b55fab980271a027428cc4d /lxqt-base/lxqt-notificationd
parentabe17cf152eeb7571da8db4b25a30465644a41ba (diff)
gentoo auto-resync : 08:11:2024 - 03:03:27
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest2
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-2.1.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index a57204f23f42..b5a696a13991 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,5 +1,7 @@
DIST lxqt-notificationd-1.4.0.tar.xz 61792 BLAKE2B e44c9e80c9fb964547902d242ea0cb5967977e4e9dad1c047daae8dadd105f97fd1cd30c5022511d9ece3c3f1e6fbf74ef79e2a5df2e2725603d3d1151dfb166 SHA512 5ae28b0f49e1e01c8d0fe96f23b961ca962dab33f16025af172777f385d0fd3471c64a7acb78b46e7dc0c370d324a17f10ec9a4c4b3afbde95d47164a5246d0a
DIST lxqt-notificationd-2.0.1.tar.xz 64132 BLAKE2B 55d0c7f785528acde181161c0d0c4f61f952700f90e535d00ab7009d768f8118e54a6ab10a75e3e3dda2def4fc395720de89701e4fc3ec0927aa9bd346c7723c SHA512 c2a532e61129f09dde253f7499485f85088c19f8cc6f5ddfd1949eb9d43b142ee4f3f526b38a70fbe276623c1637398c70470f24bcdbb5597a499354e9840d67
+DIST lxqt-notificationd-2.1.0.tar.xz 65356 BLAKE2B e5a51ca8b380373ff2527c0c4fa0e903ea0cbe510e3587ca997d255e4ae6fce237f4a660ec90c6c5d1591e5213587a5ba5e417116e513c52400fe89efcb97738 SHA512 4bb72c8303161c036febfe88ee2a1b32f24f61d2fe17d86d1077045e7784cf31cade0138f526f49c408402f4b81143af0106093569654dd4d579cbb1dd036808
EBUILD lxqt-notificationd-1.4.0.ebuild 811 BLAKE2B 43b5d246d67a707bf500eb6abc9f39ba938f3171ed9c3271f43d058e80f1da65926d0b3cd2fb831219307c44660e7873ec19141836da3f4e651b8a7835f07e00 SHA512 7ca301caa0c1af746e2c1dc8acb045b3a9c941d1aaf967f533264a6a37b348b416dd1884b7eea0b6f897e6a43e629b803a299b28632ba7a02dc2efda293c2a94
EBUILD lxqt-notificationd-2.0.1.ebuild 784 BLAKE2B 3452dab2d5b38adbb757b8f6b04fb6c1e296a48d767de8f22f8cfa4324fcd641b8cbbdf4749a99d05a429e9993f3d40381c956b438cc338d18efdb229fc8bb5b SHA512 2ef54b85a31302674fc542e7683c16911ad74bbdf45169faa8f238813ddc4d54599643da11ed0c270da987be86688f0502d3c348bf2912c4a616896f5a8617b5
+EBUILD lxqt-notificationd-2.1.0.ebuild 786 BLAKE2B 3a87fc010350b0e21ed1ef260a3694c5d98af7aa9db00a8482670b1e838a6628a9ea39642186687af5d9a97f6ec5c30c3eacd532ebe51007df5edc177524c332 SHA512 a53575312dadce21a8ffec62a2460cb51052d3a31e1ad56ba5bb4089e0779e989616ecc7c5bdd2c68f98d6f03f078dbcc072b23cb5f26913070296f2d0b3cabf
MISC metadata.xml 324 BLAKE2B 9a9ade6923097018d9e6caa51617b06c04df45227a4afbf512e04a54e2e5387f162c9b48483ff0f2fa9451a118f8b372bd1d3a487a0be2f3c896524611fe97c6 SHA512 252b5a4a24e16a6cc461670adafccb7041a8229414bd68e564ceadab8bd1ee7141fc43d8db9b6a04c161c947749c28e21815d40f49f44ea049a23167d408368f
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.1.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.1.0.ebuild
new file mode 100644
index 000000000000..8c70f75f8ac2
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.1.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-4.1.0
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ kde-frameworks/kwindowsystem:6
+ >=kde-plasma/layer-shell-qt-6.0:6
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"