summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.0.0.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.0.0.ebuild')
-rw-r--r--lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.0.0.ebuild b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.0.0.ebuild
new file mode 100644
index 000000000000..24fcc33ddee8
--- /dev/null
+++ b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt OpenSSH user password prompt tool"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+
+ newenvd - 99${PN} <<- _EOF_
+ SSH_ASKPASS='${EPREFIX}/usr/bin/lxqt-openssh-askpass'
+ _EOF_
+}