summaryrefslogtreecommitdiff
path: root/mail-client/alot/alot-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /mail-client/alot/alot-9999.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'mail-client/alot/alot-9999.ebuild')
-rw-r--r--mail-client/alot/alot-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/mail-client/alot/alot-9999.ebuild b/mail-client/alot/alot-9999.ebuild
index 57b2fe26c31e..497e1230e10c 100644
--- a/mail-client/alot/alot-9999.ebuild
+++ b/mail-client/alot/alot-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -33,19 +33,20 @@ RDEPEND="
>=dev-python/twisted-18.4[${PYTHON_USEDEP}]
net-mail/mailbase
net-mail/notmuch[crypt,python]
- "
+"
DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
test? (
- ${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
)
- "
+"
PATCHES=(
"${FILESDIR}/${PV}-0001-remove-non-working-test.patch"
"${FILESDIR}/${PV}-0002-update-reference-to-envelope-body.patch"
- )
+)
distutils_enable_tests setup.py