summaryrefslogtreecommitdiff
path: root/mail-client/roundcube
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /mail-client/roundcube
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest2
-rw-r--r--mail-client/roundcube/roundcube-1.6.8.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index a2cf2748ba04..d0bce2f63881 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,5 +1,7 @@
AUX POST-UPGRADE_complete.txt 854 BLAKE2B e99a1ec9a316c90ee4adc112dd87f394d0e2ce37ca5d1195e3f812683a2da59bedf45688cd448cc3ca544a02ee1c0e125f3960e81a062b0f7949e2cde581563d SHA512 0328842265ca859e78fa7d5babeac7b6baa16fb25962f50d431bbca133d042694d98942f77ba3387832d66645cc4df8fb9f3c4591ca7ed4eade6782a92a3d445
DIST roundcubemail-1.6.7-complete.tar.gz 5899345 BLAKE2B c22803f3651c32f863081afe28d05e4b7918ba0cb1238c11de646a0fe3a16a6faff633a3a193a5813a50be710a71a8900d049f0e628661b6c7c036c0d69055ab SHA512 aedc940e769e881d448eced2ef0b603c87f9a9e18624cae4d14a946e6f9509c827f75e6fb294a760970e37caa9ab0bfb0a7ec8843b12542f59f350948d2d8d3b
+DIST roundcubemail-1.6.8-complete.tar.gz 5899212 BLAKE2B c5069fb038afe96dda75c815e564b23c629dc5683af7f428622556045f84e1cbe38b163609a6faefbc86d94d6f0bbab6778e9e62830fe68f98ea311cfbbdbbe1 SHA512 91bf08d5c2643b81efee87cae7045adad7fd6867bef6847ff64eac2490d84b38d08a8c6622fb947da67ecd43eaecb83ab4f3b5ebecc75e9f6dd511db6eb88128
EBUILD roundcube-1.6.7.ebuild 2352 BLAKE2B 74f92f8dcfdab1f4fda63261afe5d905fa70cd5f5e904a8d7c4c0cf0d3f4f96f074be984d3be2aa4e685b695b069c142c207eb209419eac9f7e248d7a80b0e50 SHA512 73c0d88e80b2bbd6bc3600565fe06e5dc8a4c46ce59d52653c34aaa6247ab8fe19445d974962c69c9d3c76aae8d58352a89525df8a6e381bf93dbce09d8d3ebd
+EBUILD roundcube-1.6.8.ebuild 2358 BLAKE2B 9f363f0acfbb715b97012ea3c3710393a247e6ebdd289da3e77ce975b38e6373b0702f083371846ae55a0f0222db96cc7c4edd66d94492cc279dfff73c3d9131 SHA512 b4fd1926373e027678ed5da0049da4c6ae9ede00daf104f8f8ac6c14731d2073efa9fcb2dcc8cbf7c2cadaab2eeb3ae77e746cb5b5216b8ed5edebcee1302a8c
EBUILD roundcube-9999.ebuild 2356 BLAKE2B 34bc19151f4b75bddf7968f3525a25250a1e7d9835459324bddfb58e5453f77397ef148ff483528f5f7dbcba0f356e0e0e18492347b9321cbce81336ae8196ce SHA512 fcc05cdda5945ddf0e843052cb0011a4c5007d7547b586b54aa1bdfe49ae9f3f7b1307d1756d46ca365d669419be1a377810aacd07c4e1ebd653a15d99d194c7
MISC metadata.xml 1128 BLAKE2B b7ecf906ab635d9100c5c28e9950ff9a0d746a797502a672e8a8f3f2da36a67b4f42863133548dfe3b415382d8fe116229cdc6d24f7df1db0cdf3a4a9da7a4f3 SHA512 35e05c40b1175760b0e171acce265b1a5f0748824f010dfb93d7d3345e595c0814ba8ebd2ddfdb699893b5fd7fdd19fed68eccd3ec94a816876b88550412c486
diff --git a/mail-client/roundcube/roundcube-1.6.8.ebuild b/mail-client/roundcube/roundcube-1.6.8.ebuild
new file mode 100644
index 000000000000..e8f09db98c3b
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.6.8.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-7.4.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
+ EGIT_BRANCH="master"
+ BDEPEND="${BDEPEND}
+ app-arch/unzip
+ dev-php/composer
+ net-misc/curl"
+else
+ SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ rm Makefile || die
+ mv composer.json-dist composer.json || die
+ composer install --no-dev || die
+ ./bin/install-jsdeps.sh || die
+ popd > /dev/null || die
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}