summaryrefslogtreecommitdiff
path: root/mail-client/thunderbird
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 18:57:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 18:57:09 +0000
commit0a610f61a00066203da0b0ed9ba215efbb480f4f (patch)
tree40c29df923316d472b90e9a4316b4841720a93d6 /mail-client/thunderbird
parent34fb4543abc1dae6f74171ad8dc80fa64636a941 (diff)
gentoo auto-resync : 17:11:2022 - 18:57:09
Diffstat (limited to 'mail-client/thunderbird')
-rw-r--r--mail-client/thunderbird/Manifest2
-rw-r--r--mail-client/thunderbird/thunderbird-102.5.0.ebuild26
2 files changed, 9 insertions, 19 deletions
diff --git a/mail-client/thunderbird/Manifest b/mail-client/thunderbird/Manifest
index 53bc847aa2cb..f9836e475b74 100644
--- a/mail-client/thunderbird/Manifest
+++ b/mail-client/thunderbird/Manifest
@@ -203,5 +203,5 @@ DIST thunderbird-102.5.0-zh-TW.xpi 725969 BLAKE2B 863f00e7b37197d42c3400ab28d056
DIST thunderbird-102.5.0.source.tar.xz 506950192 BLAKE2B 7374644b6601358b9ac10694faf15bcfee20a92b00905b6d8321964996682512bbd3b57ab44ebcdeeb5f10ff297d14ce56f8c28482ab9fefa2ccf67df0adbc08 SHA512 b6f2828b23616db5620e0364a1ebb02a8676e184d5e361c0aa87f36b64eb6b7f4b1bc3c42675b3ae3092953fbda6b01c18c068b167d40469481b1e18af1dcaa1
EBUILD thunderbird-102.4.0.ebuild 33402 BLAKE2B 8ebbb46776ba1e5e65654775a798b20f3a164987a4359c48f26277e01c8f4be4457d802bd6b28c4f0119f91c7785ca15f05cda604a4dac0fc2874f2d0dc46daf SHA512 9c7a7bad143f6b5f893a10fd3ad08b87dc8fe185b819a417fcce29b9f35e068f747bb629cd8f695c6bbe5b6104f37901afdc58edf5bd3cf7c1aac0d89b5125b0
EBUILD thunderbird-102.4.2.ebuild 33404 BLAKE2B 298b3ed02874ff34fce7398217620da9caf71938333829c33c28586209cad21ffb87f9d7cd5548c1d3541e811d5de3018a3acd18be3897f7f930ff3785097bca SHA512 f5ff830bad5ca7dee95de145af883053582b955940c80d25c4382e44bf1747fd76bcb08e3d4c4ae5be8a517c95bf7fa66bb5a0225b16070d67b1b8bb681b9e67
-EBUILD thunderbird-102.5.0.ebuild 34182 BLAKE2B 7015d22bb7824156ddd40d85b144cf4cbcaf69e071b15dcee750054d44904c14b39278a6ef270ca4f77b57f0e868f68e5299bbe4d3e8fdb224aca5d1a40a9231 SHA512 72283ee924b9e036a03abfa7dfa1c449e891a79cc53062f4f9f9015dfed7d6c0d02247cc4666d6a7fb988066ca52883448667b7e251c5ce024d4139cd384dbe4
+EBUILD thunderbird-102.5.0.ebuild 33866 BLAKE2B f5b3274f07693353fdd5a5592ff159117619521ee2d4dd52b743f659e27210a4e3a1002ba403839cf7437d52350c98374626b825f035a91e8f0287f47b96db74 SHA512 d7ac08d93bc25a9a8427ef36bc9170e84fbfa8e78e546e5bc180100ba90ce90c481b63eb338dbf2a7a51c87de61797fc6d2754bb2d6e11a12f9210a18eb5b86b
MISC metadata.xml 2139 BLAKE2B c348f9dc2bf813c386bc2e62782bf762ef4fdaf3f913cec41bbd115a7bac54b01852dec04e6f7574b24ea5cd6d9500f289109127cdac5887128b07116d6a6cf8 SHA512 09b0670e852cc954b5df5e846935d274ae180e4627d112104d5fedf2a777fda7d52d73cdfde9e50475d9a560ed44946d4c0682d52d793bbfb5f2e1b1e0aac608
diff --git a/mail-client/thunderbird/thunderbird-102.5.0.ebuild b/mail-client/thunderbird/thunderbird-102.5.0.ebuild
index 9d4698c7519d..69b2c9fb81f6 100644
--- a/mail-client/thunderbird/thunderbird-102.5.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-102.5.0.ebuild
@@ -87,6 +87,7 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/llvm:15
clang? (
sys-devel/lld:15
+ virtual/rust:0/llvm-15
pgo? ( =sys-libs/compiler-rt-sanitizers-15*[profile] )
)
)
@@ -95,14 +96,12 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/llvm:14
clang? (
sys-devel/lld:14
+ virtual/rust:0/llvm-14
pgo? ( =sys-libs/compiler-rt-sanitizers-14*[profile] )
)
)
)
- || (
- virtual/rust:0/llvm-15
- virtual/rust:0/llvm-14
- )
+ !clang? ( virtual/rust )
app-arch/unzip
app-arch/zip
>=dev-util/cbindgen-0.24.3
@@ -208,6 +207,11 @@ llvm_check_deps() {
return 1
fi
+ if ! has_version -b "virtual/rust:0/llvm-${LLVM_SLOT}" ; then
+ einfo "virtual/rust:0/llvm-${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ return 1
+ fi
+
if use pgo ; then
if ! has_version -b "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
einfo "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing! Cannot use LLVM slot ${LLVM_SLOT} ... Please try emerge -1av =sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* with profile use flag on!" >&2
@@ -397,20 +401,6 @@ pkg_setup() {
check-reqs_pkg_setup
- # Attempt to force a specific llvm/clang/lld with multiple llvm toolchain slots installed.
- local LLVM_USE_SLOT=${LLVM_MAX_SLOT}
- if $(has_version "virtual/rust:0/llvm-${LLVM_USE_SLOT}"); then
- :
- else
- ((LLVM_USE_SLOT=LLVM_USE_SLOT-1))
- if $(has_version "virtual/rust:0/llvm-${LLVM_USE_SLOT}"); then
- :
- else
- die "Couldn't find virtual/rust:0/llvm-${LLVM_MAX_SLOT} or virtual/rust:0/llvm-${LLVM_USE_SLOT}. Check your virtual/rust installation."
- fi
- fi
-
- local LLVM_MAX_SLOT=${LLVM_USE_SLOT}
llvm_pkg_setup
if use clang && use lto ; then