summaryrefslogtreecommitdiff
path: root/mail-filter/mapson/mapson-3.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /mail-filter/mapson/mapson-3.3-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'mail-filter/mapson/mapson-3.3-r1.ebuild')
-rw-r--r--mail-filter/mapson/mapson-3.3-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/mail-filter/mapson/mapson-3.3-r1.ebuild b/mail-filter/mapson/mapson-3.3-r1.ebuild
new file mode 100644
index 000000000000..9903dbb7f789
--- /dev/null
+++ b/mail-filter/mapson/mapson-3.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A challenge/response-based white-list spam filter"
+HOMEPAGE="http://mapson.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mapson/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug"
+
+RDEPEND="
+ acct-user/mail
+ virtual/mta
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3-gcc6.patch
+ "${FILESDIR}"/${PN}-3.3-respect-AR.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with debug)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ dodoc AUTHORS INSTALL NEWS README
+ doman doc/mapson.1
+
+ docinto html
+ dodoc doc/mapson.html
+
+ insinto /etc/mapson
+ newins sample-config mapson.config
+
+ insinto /usr/share/mapson
+ newins sample-challenge-template challenge-template
+
+ rm -f "${ED}"/etc/sample-config || die
+ rm -f "${ED}"/usr/share/{mapson.html,sample-challenge-template} || die
+}