summaryrefslogtreecommitdiff
path: root/mail-filter/rspamd/files/rspamd-2.6-unbundle-lua.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /mail-filter/rspamd/files/rspamd-2.6-unbundle-lua.patch
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'mail-filter/rspamd/files/rspamd-2.6-unbundle-lua.patch')
-rw-r--r--mail-filter/rspamd/files/rspamd-2.6-unbundle-lua.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/mail-filter/rspamd/files/rspamd-2.6-unbundle-lua.patch b/mail-filter/rspamd/files/rspamd-2.6-unbundle-lua.patch
new file mode 100644
index 000000000000..9278fa8608d7
--- /dev/null
+++ b/mail-filter/rspamd/files/rspamd-2.6-unbundle-lua.patch
@@ -0,0 +1,53 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b794b9dbd..1ba5c085e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -632,10 +632,6 @@ ADD_SUBDIRECTORY(contrib/fastutf8)
+ ADD_SUBDIRECTORY(contrib/google-ced)
+
+
+-IF (NOT WITH_LUAJIT)
+- ADD_SUBDIRECTORY(contrib/lua-bit)
+-ENDIF()
+-
+ IF (ENABLE_LUA_REPL MATCHES "ON")
+ ADD_SUBDIRECTORY(contrib/replxx)
+ SET(WITH_LUA_REPL 1)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 9a34d2ac4..59bab5c15 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -189,10 +189,6 @@ IF (ENABLE_CLANG_PLUGIN MATCHES "ON")
+ ADD_DEPENDENCIES(rspamd-server rspamd-clang)
+ ENDIF()
+
+-IF (NOT WITH_LUAJIT)
+- TARGET_LINK_LIBRARIES(rspamd-server rspamd-bit)
+-ENDIF()
+-
+ IF (ENABLE_SNOWBALL MATCHES "ON")
+ TARGET_LINK_LIBRARIES(rspamd-server stemmer)
+ ENDIF()
+diff --git a/src/lua/lua_common.c b/src/lua/lua_common.c
+index b7fcc2034..1d86464da 100644
+--- a/src/lua/lua_common.c
++++ b/src/lua/lua_common.c
+@@ -922,10 +922,6 @@ rspamd_lua_wipe_realloc (void *ud,
+ return NULL;
+ }
+
+-#ifndef WITH_LUAJIT
+-extern int luaopen_bit(lua_State *L);
+-#endif
+-
+ lua_State *
+ rspamd_lua_init (bool wipe_mem)
+ {
+@@ -981,7 +977,6 @@ rspamd_lua_init (bool wipe_mem)
+ luaopen_spf (L);
+ luaopen_tensor (L);
+ #ifndef WITH_LUAJIT
+- rspamd_lua_add_preload (L, "bit", luaopen_bit);
+ lua_settop (L, 0);
+ #endif
+