summaryrefslogtreecommitdiff
path: root/mail-filter/zdkimfilter/zdkimfilter-1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /mail-filter/zdkimfilter/zdkimfilter-1.8.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'mail-filter/zdkimfilter/zdkimfilter-1.8.ebuild')
-rw-r--r--mail-filter/zdkimfilter/zdkimfilter-1.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail-filter/zdkimfilter/zdkimfilter-1.8.ebuild b/mail-filter/zdkimfilter/zdkimfilter-1.8.ebuild
new file mode 100644
index 000000000000..6205edee11c4
--- /dev/null
+++ b/mail-filter/zdkimfilter/zdkimfilter-1.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DESCRIPTION="DKIM filter for Courier-MTA"
+HOMEPAGE="https://www.tana.it/sw/zdkimfilter"
+SRC_URI="https://www.tana.it/sw/zdkimfilter/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="mail-filter/opendkim
+ mail-mta/courier
+ dev-db/opendbx
+ dev-libs/nettle
+ net-dns/libidn2
+ dev-libs/libunistring"
+RDEPEND="${DEPEND}"
+
+# For working tests we need a fix for opendkim,
+# see https://bugs.gentoo.org/700174
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ diropts -o mail -g mail
+ dodir /etc/courier/filters/keys
+ dodoc release-notes-*.txt README ChangeLog
+ dodoc odbx_example.{conf,sql}
+}