summaryrefslogtreecommitdiff
path: root/mail-mta/notqmail/notqmail-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /mail-mta/notqmail/notqmail-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'mail-mta/notqmail/notqmail-9999.ebuild')
-rw-r--r--mail-mta/notqmail/notqmail-9999.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/mail-mta/notqmail/notqmail-9999.ebuild b/mail-mta/notqmail/notqmail-9999.ebuild
index d622c556ab57..6ce036b2f82c 100644
--- a/mail-mta/notqmail/notqmail-9999.ebuild
+++ b/mail-mta/notqmail/notqmail-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,8 +17,14 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/notqmail/notqmail.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- SRC_URI="https://github.com/notqmail/notqmail/releases/download/${P}/${P}.tar.xz"
+ inherit verify-sig
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ SRC_URI="
+ https://github.com/notqmail/notqmail/releases/download/${P}/${P}.tar.xz
+ verify-sig? (
+ https://github.com/notqmail/notqmail/releases/download/${P}/${P}.tar.xz.sig
+ )
+ "
fi
DESCRIPTION="Collaborative open-source successor to qmail"
@@ -51,12 +57,17 @@ SRC_URI="${SRC_URI}
)
"
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/notqmail.asc
+
LICENSE="public-domain"
SLOT="0"
IUSE="authcram gencertdaily highvolume pop3 qmail-spp ssl test vanilla"
REQUIRED_USE="vanilla? ( !ssl !qmail-spp !highvolume !authcram !gencertdaily ) gencertdaily? ( ssl )"
RESTRICT="!test? ( test )"
+if [[ ${PV} != 9999 ]] ; then
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-notqmail )"
+fi
DEPEND="
net-dns/libidn2
net-mail/queue-repair
@@ -99,12 +110,15 @@ src_unpack() {
genqmail_src_unpack
[[ ${PV} == "9999" ]] && git-r3_src_unpack
- [[ ${PV} != "9999" ]] && default
+ if [[ ${PV} != "9999" ]]; then
+ default
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+ fi
}
src_prepare() {
- PATCHES=()
-
if ! use vanilla; then
if use qmail-spp; then
PATCHES+=( "${DISTDIR}/${P}-auth.patch" )