summaryrefslogtreecommitdiff
path: root/mail-mta/qpsmtpd/qpsmtpd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /mail-mta/qpsmtpd/qpsmtpd-9999.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'mail-mta/qpsmtpd/qpsmtpd-9999.ebuild')
-rw-r--r--mail-mta/qpsmtpd/qpsmtpd-9999.ebuild39
1 files changed, 26 insertions, 13 deletions
diff --git a/mail-mta/qpsmtpd/qpsmtpd-9999.ebuild b/mail-mta/qpsmtpd/qpsmtpd-9999.ebuild
index 801cfb710759..2964681181e3 100644
--- a/mail-mta/qpsmtpd/qpsmtpd-9999.ebuild
+++ b/mail-mta/qpsmtpd/qpsmtpd-9999.ebuild
@@ -1,18 +1,23 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils perl-module user git-r3
+[[ ${PV} == *9999 ]] && SCM="git-r3"
+inherit perl-module user ${SCM}
DESCRIPTION="qpsmtpd is a flexible smtpd daemon written in Perl"
HOMEPAGE="https://smtpd.github.io/qpsmtpd/"
-# This is a spotted development fork with many improvements
-EGIT_REPO_URI="https://github.com/smtpd/${PN}.git"
+if [[ ${PV} != *9999 ]]; then
+ SRC_URI="https://github.com/smtpd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ # This is a spotted development fork with many improvements
+ EGIT_REPO_URI="https://github.com/smtpd/${PN}.git"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="postfix ipv6 syslog"
RDEPEND=">=dev-lang/perl-5.8.0
@@ -37,6 +42,16 @@ pkg_setup() {
enewuser smtpd -1 -1 /var/spool/qpsmtpd smtpd${additional_groups}
}
+src_unpack() {
+ if [[ ${PV} != *9999 ]]; then
+ unpack ${A}
+ cd "${S}"
+ else
+ git-r3_src_unpack
+ cd "${S}"
+ fi
+}
+
src_install() {
perl-module_src_install
@@ -44,25 +59,23 @@ src_install() {
newins "${FILESDIR}"/qpsmtpd.xinetd qpsmtpd
dodir /usr/share/qpsmtpd
- cp -Rf plugins "${D}"/usr/share/qpsmtpd/
+ cp -Rf plugins "${ED}"/usr/share/qpsmtpd/ || die
diropts -m 0755 -o smtpd -g smtpd
- dodir /var/spool/qpsmtpd
keepdir /var/spool/qpsmtpd
- dodir /etc/qpsmtpd
insinto /etc/qpsmtpd
doins config.sample/*
- echo "/usr/share/qpsmtpd/plugins" > "${D}"/etc/qpsmtpd/plugin_dirs
- echo "/var/spool/qpsmtpd" > "${D}"/etc/qpsmtpd/spool_dir
+ echo "/usr/share/qpsmtpd/plugins" > "${ED}"/etc/qpsmtpd/plugin_dirs || die
+ echo "/var/spool/qpsmtpd" > "${ED}"/etc/qpsmtpd/spool_dir || die
if use syslog; then
- echo "logging/syslog loglevel LOGINFO priority LOG_NOTICE" > "${D}"/etc/qpsmtpd/logging
+ echo "logging/syslog loglevel LOGINFO priority LOG_NOTICE" > "${ED}"/etc/qpsmtpd/logging
else
diropts -m 0755 -o smtpd -g smtpd
dodir /var/log/qpsmtpd
keepdir /var/log/qpsmtpd
- echo "logging/file loglevel LOGINFO /var/log/qpsmtpd/%Y-%m-%d" > "${D}"/etc/qpsmtpd/logging
+ echo "logging/file loglevel LOGINFO /var/log/qpsmtpd/%Y-%m-%d" > "${ED}"/etc/qpsmtpd/logging
fi
newenvd "${FILESDIR}"/qpsmtpd.envd 99qpsmtpd