summaryrefslogtreecommitdiff
path: root/mail-mta/sendmail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /mail-mta/sendmail
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'mail-mta/sendmail')
-rw-r--r--mail-mta/sendmail/Manifest2
-rw-r--r--mail-mta/sendmail/sendmail-8.16.1-r1.ebuild207
-rw-r--r--mail-mta/sendmail/sendmail-8.16.1.ebuild209
3 files changed, 208 insertions, 210 deletions
diff --git a/mail-mta/sendmail/Manifest b/mail-mta/sendmail/Manifest
index eea08a721157..e2a42488492d 100644
--- a/mail-mta/sendmail/Manifest
+++ b/mail-mta/sendmail/Manifest
@@ -14,5 +14,5 @@ AUX sm-client.service 418 BLAKE2B a9057cac008c11d3cfd5a4b662cf3fc71a33be79e8890a
DIST sendmail.8.15.2.tar.gz 2207417 BLAKE2B 3d9dfb5bc2b535e30ef2fc61333e12a9b1fc45a5d730d2bed1ef956adb574721833f87aeba0475705b76e0c7d6cf00f9a10025bffb0de6c6b4dae606eb2ec399 SHA512 04feb37316c13b66b1518596507a7da7c16cb0bf1abf10367f7fd888a428fadb093a9efa55342fa55b936c3f0cbdc63b9e2505cd99201a69a0c05b8ad65f49f9
DIST sendmail.8.16.1.tar.gz 2236402 BLAKE2B 80a9c2f1d04719099703e55f0a0c54fd638cf69b72839d358ae6863c95c9e0965d1b7fdd5b1807bec1ffdf87bca0c7c9ba91060962e6de5da5bf14422f6279ea SHA512 d7d4aac3c6d7505782abdb166204901b8b51cac000d610dfe40eda9eef7441a073af9e8e0b14c8719b07b445f55a1e2c28ac63d663d0daa7f1eafc5a101788b2
EBUILD sendmail-8.15.2-r2.ebuild 7199 BLAKE2B 801a30a6d9d71d3aa34ddf3910c9bb4658d687905b3df1e17052b9bbab692db74d2e703906cff948ba173684e08668f44274afb2fd9d269f51607dd2318a8d46 SHA512 9a8e3c5118e64bad84082d34b9593aec4b3bbf7bee23aea056a32b1d5bdae797086d4a0e342f217cd91bec9dc112cd387b7c02401eb800ac7f613fd5eecbcbb2
-EBUILD sendmail-8.16.1.ebuild 6480 BLAKE2B 3bd092503dd0ed465f7d7690be9850705b34d4d2c3ceace4694a693e79bb7828246f8fb8c38180ae3233aff13ccbaa287c7d0266c4ee73a19ca3cc18bcca2b3e SHA512 e18bf609e018aaaf6173ccf7adc4948b16153f6b7b521df251012b2e8cae878be21cd329745a9d0d76240e72b705aa79d4041df184e2c7f5d5acdb4634f9db00
+EBUILD sendmail-8.16.1-r1.ebuild 6217 BLAKE2B 0a6a986ddd360009711f62adbed2e7d3f468561a78b299b5c72d2d0053657b1b096a2d0864f783b065a08f345d40ba4ce30c8ecf724886570831303764ef2abd SHA512 458d3414662545a99d4994b3cc701956404b8759ac6a91c7faac6916d081c4b363de3bb10c5a89a447b35a090fdc7d9b7cd12c9deb2588c0560b0a1cde7a31af
MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/mail-mta/sendmail/sendmail-8.16.1-r1.ebuild b/mail-mta/sendmail/sendmail-8.16.1-r1.ebuild
new file mode 100644
index 000000000000..8b5b4f3cdc07
--- /dev/null
+++ b/mail-mta/sendmail/sendmail-8.16.1-r1.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Note: please bump this together with mail-filter/libmilter
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Widely-used Mail Transport Agent (MTA)"
+HOMEPAGE="https://www.sendmail.org/"
+SRC_URI="ftp://ftp.sendmail.org/pub/${PN}/${PN}.${PV}.tar.gz"
+
+LICENSE="Sendmail GPL-2" # GPL-2 is here for initscript
+SLOT="0"
+# TODO: restore keywords soon for bug 730890 after testing
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ipv6 ldap mbox nis sasl sockets ssl tcpd"
+
+BDEPEND="
+ sys-devel/m4
+ virtual/pkgconfig"
+DEPEND="
+ net-mail/mailbase
+ >=sys-libs/db-3.2:=
+ ldap? ( net-nds/openldap )
+ nis? ( net-libs/libnsl:= )
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.10 )
+ ssl? ( dev-libs/openssl:0= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="
+ ${DEPEND}
+ acct-group/smmsp
+ >=acct-user/smmsp-0-r2
+ >=mail-filter/libmilter-1.0.2_p1-r1
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp[mta]
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/opensmtpd
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !>=mail-mta/ssmtp-2.64-r2[mta]
+ !net-mail/vacation"
+PDEPEND="!mbox? ( mail-filter/procmail )"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-8.16.1-build-system.patch
+ eapply -p0 "${FILESDIR}"/${PN}-delivered_hdr.patch
+ eapply_user
+
+ local confCCOPTS="${CFLAGS}"
+ local confENVDEF="-DMAXDAEMONS=64 -DHAS_GETHOSTBYNAME2=1"
+ local confLDOPTS="${LDFLAGS}"
+ local confLIBS=
+ local confMAPDEF="-DMAP_REGEX"
+ local conf_sendmail_LIBS=
+
+ if use ldap; then
+ confMAPDEF+=" -DLDAPMAP"
+ confLIBS+=" -lldap -llber"
+ fi
+
+ if use sasl; then
+ confCCOPTS+=" $($(tc-getPKG_CONFIG) --cflags libsasl2)"
+ confENVDEF+=" -DSASL=2"
+ conf_sendmail_LIBS+=" $($(tc-getPKG_CONFIG) --libs libsasl2)"
+ fi
+
+ if use ssl; then
+ # Bug #542370 - lets add support for modern crypto (PFS)
+ confCCOPTS+=" $($(tc-getPKG_CONFIG) --cflags openssl)"
+ confENVDEF+=" -DSTARTTLS -D_FFR_DEAL_WITH_ERROR_SSL"
+ confENVDEF+=" -D_FFR_TLS_1 -D_FFR_TLS_EC"
+ conf_sendmail_LIBS+=" $($(tc-getPKG_CONFIG) --libs openssl)"
+ fi
+
+ if use tcpd; then
+ confENVDEF+=" -DTCPWRAPPERS"
+ confLIBS+=" -lwrap"
+ fi
+
+ use ipv6 && confENVDEF+=" -DNETINET6"
+ use nis && confENVDEF+=" -DNIS"
+ use sockets && confENVDEF+=" -DSOCKETMAP"
+
+ sed -e "s|@@confCC@@|$(tc-getCC)|" \
+ -e "s|@@confCCOPTS@@|${confCCOPTS}|" \
+ -e "s|@@confENVDEF@@|${confENVDEF}|" \
+ -e "s|@@confLDOPTS@@|${confLDOPTS}|" \
+ -e "s|@@confLIBS@@|${confLIBS}|" \
+ -e "s|@@confMAPDEF@@|${confMAPDEF}|" \
+ -e "s|@@conf_sendmail_LIBS@@|${conf_sendmail_LIBS}|" \
+ "${FILESDIR}"/site.config.m4 > devtools/Site/site.config.m4 \
+ || die "failed to generate site.config.m4"
+
+ echo "APPENDDEF(\`confLIBDIRS', \`-L${EPREFIX}/usr/$(get_libdir)')" \
+ >> devtools/Site/site.config.m4 || die "failed adding to site.config.m4"
+}
+
+src_compile() {
+ sh Build AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "compilation failed in main build script"
+}
+
+src_install() {
+ dodir /usr/{bin,$(get_libdir)}
+ dodir /usr/share/man/man{1,5,8} /usr/sbin /usr/share/sendmail-cf
+ dodir /var/spool/{mqueue,clientmqueue} /etc/conf.d
+
+ keepdir /var/spool/{clientmqueue,mqueue}
+
+ local emakeargs=(
+ DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)"
+ MANROOT=/usr/share/man/man
+ SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root
+ MANOWN=root MANGRP=root INCOWN=root INCGRP=root
+ LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root
+ MSPQOWN=root CFOWN=root CFGRP=root
+ )
+
+ local dir
+ for dir in libsmutil sendmail mailstats praliases smrsh makemap vacation editmap; do
+ emake -j1 -C obj.*/${dir} "${emakeargs[@]}" install
+ done
+ for dir in rmail mail.local; do
+ emake -j1 -C obj.*/${dir} "${emakeargs[@]}" force-install
+ done
+
+ fowners root:smmsp /usr/sbin/sendmail
+ fperms 2555 /usr/sbin/sendmail
+ fowners smmsp:smmsp /var/spool/clientmqueue
+ fperms 770 /var/spool/clientmqueue
+ fperms 700 /var/spool/mqueue
+ dosym ../sbin/makemap /usr/bin/makemap
+ dodoc FAQ KNOWNBUGS README RELEASE_NOTES doc/op/op.ps
+
+ dodoc sendmail/{SECURITY,TUNING}
+ newdoc sendmail/README README.sendmail
+ newdoc smrsh/README README.smrsh
+
+ newdoc cf/README README.cf
+ newdoc cf/cf/README README.install-cf
+
+ dodoc -r contrib
+
+ cp -pPR cf/. "${ED}"/usr/share/sendmail-cf || die
+
+ insinto /etc/mail
+ if use mbox; then
+ newins "${FILESDIR}"/sendmail.mc-r1 sendmail.mc
+ else
+ newins "${FILESDIR}"/sendmail-procmail.mc sendmail.mc
+ fi
+
+ # See discussion on bug #730890
+ m4 "${ED}"/usr/share/sendmail-cf/m4/cf.m4 \
+ <(grep -v "${EPREFIX}"/usr/share/sendmail-cf/m4/cf.m4 "${ED}"/etc/mail/sendmail.mc) \
+ > "${ED}"/etc/mail/sendmail.cf || die "cf.m4 failed"
+
+ echo "include(\`/usr/share/sendmail-cf/m4/cf.m4')dnl" \
+ > "${ED}"/etc/mail/submit.mc || die "submit.mc echo failed"
+
+ cat "${ED}"/usr/share/sendmail-cf/cf/submit.mc \
+ >> "${ED}"/etc/mail/submit.mc || die "submit.mc cat failed"
+
+ echo "# local-host-names - include all aliases for your machine here" \
+ > "${ED}"/etc/mail/local-host-names || die "local-host-names echo failed"
+
+ cat <<- EOF > "${ED}"/etc/mail/trusted-users || die "trusted-users cat failed"
+ # trusted-users - users that can send mail as others without a warning
+ # apache, mailman, majordomo, uucp are good candidates
+ EOF
+
+ cat <<- EOF > "${ED}"/etc/mail/access || die "access cat failed"
+ # Check the /usr/share/doc/sendmail/README.cf file for a description
+ # of the format of this file. (search for access_db in that file)
+ # The /usr/share/doc/sendmail/README.cf is part of the sendmail-doc
+ # package.
+ #
+
+ EOF
+
+ cat <<- EOF > "${ED}"/etc/conf.d/sendmail || die "sendmail cat failed"
+ # Config file for /etc/init.d/sendmail
+ # add start-up options here
+ SENDMAIL_OPTS="-bd -q30m -L sm-mta" # default daemon mode
+ CLIENTMQUEUE_OPTS="-Ac -q30m -L sm-cm" # clientmqueue
+ KILL_OPTS="" # add -9/-15/your favorite evil SIG level here
+
+ EOF
+
+ if use sasl; then
+ dodir /etc/sasl2
+ cat <<- EOF > "${ED}"/etc/sasl2/Sendmail.conf || die "Sendmail.conf cat ailed"
+ pwcheck_method: saslauthd
+ mech_list: PLAIN LOGIN
+
+ EOF
+ fi
+
+ doinitd "${FILESDIR}"/sendmail
+ systemd_dounit "${FILESDIR}"/sendmail.service
+ systemd_dounit "${FILESDIR}"/sm-client.service
+}
diff --git a/mail-mta/sendmail/sendmail-8.16.1.ebuild b/mail-mta/sendmail/sendmail-8.16.1.ebuild
deleted file mode 100644
index 56796fa2dc58..000000000000
--- a/mail-mta/sendmail/sendmail-8.16.1.ebuild
+++ /dev/null
@@ -1,209 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib systemd toolchain-funcs
-
-DESCRIPTION="Widely-used Mail Transport Agent (MTA)"
-HOMEPAGE="https://www.sendmail.org/"
-SRC_URI="ftp://ftp.sendmail.org/pub/${PN}/${PN}.${PV}.tar.gz"
-
-LICENSE="Sendmail GPL-2" # GPL-2 is here for initscript
-SLOT="0"
-#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="ipv6 ldap mbox nis sasl sockets ssl tcpd"
-
-BDEPEND="sys-devel/m4"
-DEPEND="net-mail/mailbase
- sasl? ( >=dev-libs/cyrus-sasl-2.1.10 )
- tcpd? ( sys-apps/tcp-wrappers )
- ssl? (
- dev-libs/openssl:0=
- )
- ldap? ( net-nds/openldap )
- >=sys-libs/db-3.2:=
- !net-mail/vacation"
-RDEPEND="${DEPEND}
- acct-group/smmsp
- acct-user/smmsp
- >=net-mail/mailbase-0.00
- >=mail-filter/libmilter-1.0.2_p1-r1
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp[mta]
- !mail-mta/netqmail
- !mail-mta/nullmailer
- !mail-mta/postfix
- !mail-mta/opensmtpd
- !mail-mta/qmail-ldap
- !>=mail-mta/ssmtp-2.64-r2[mta]"
-
-PDEPEND="!mbox? ( mail-filter/procmail )"
-
-src_prepare() {
- eapply "${FILESDIR}"/"${PN}"-8.16.1-build-system.patch
- eapply -p0 "${FILESDIR}"/sendmail-delivered_hdr.patch
-
- local confCC="$(tc-getCC)"
- local confCCOPTS="${CFLAGS}"
- local confLDOPTS="${LDFLAGS}"
- local confMAPDEF="-DMAP_REGEX"
- local confENVDEF="-DMAXDAEMONS=64"
- local conf_sendmail_LIBS=""
-
- confENVDEF="${confLIBS} -DHAS_GETHOSTBYNAME2=1"
-
- use sasl && confLIBS="${confLIBS} -lsasl2" \
- && confENVDEF="${confENVDEF} -DSASL=2" \
- && confCCOPTS="${confCCOPTS} -I/usr/include/sasl" \
- && conf_sendmail_LIBS="${conf_sendmail_LIBS} -lsasl2"
-
- use tcpd && confENVDEF="${confENVDEF} -DTCPWRAPPERS" \
- && confLIBS="${confLIBS} -lwrap"
-
- # Bug #542370 - lets add support for modern crypto (PFS)
- use ssl && confENVDEF="${confENVDEF} -DSTARTTLS -D_FFR_DEAL_WITH_ERROR_SSL" \
- && confENVDEF="${confENVDEF} -D_FFR_TLS_1 -D_FFR_TLS_EC" \
- && confLIBS="${confLIBS} -lssl -lcrypto" \
- && conf_sendmail_LIBS="${conf_sendmail_LIBS} -lssl -lcrypto"
-
- use ldap && confMAPDEF="${confMAPDEF} -DLDAPMAP" \
- && confLIBS="${confLIBS} -lldap -llber"
-
- use ipv6 && confENVDEF="${confENVDEF} -DNETINET6"
-
- use nis && confENVDEF="${confENVDEF} -DNIS"
-
- use sockets && confENVDEF="${confENVDEF} -DSOCKETMAP"
-
- sed -e "s:@@confCCOPTS@@:${confCCOPTS}:" \
- -e "s/@@confLDOPTS@@/${confLDOPTS}/" \
- -e "s/@@confCC@@/${confCC}/" \
- -e "s/@@confMAPDEF@@/${confMAPDEF}/" \
- -e "s/@@confENVDEF@@/${confENVDEF}/" \
- -e "s/@@confLIBS@@/${confLIBS}/" \
- -e "s/@@conf_sendmail_LIBS@@/${conf_sendmail_LIBS}/" \
- "${FILESDIR}"/site.config.m4 > devtools/Site/site.config.m4 || die "sed failed"
-
- echo "APPENDDEF(\`confLIBDIRS', \`-L${EPREFIX}/usr/$(get_libdir)')" >> devtools/Site/site.config.m4 || die "echo failed"
-
- eapply_user
-}
-
-src_compile() {
- sh Build AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "compilation failed in main build script"
-}
-
-src_install() {
- local MY_LIBDIR=/usr/$(get_libdir)
- local MY_OBJDIR="obj.`uname -s`.`uname -r`.`uname -m`"
-
- dodir /usr/bin ${MY_LIBDIR}
- dodir /usr/share/man/man{1,5,8} /usr/sbin /usr/share/sendmail-cf
- dodir /var/spool/{mqueue,clientmqueue} /etc/conf.d
-
- keepdir /var/spool/{clientmqueue,mqueue}
-
- for dir in libsmutil sendmail mailstats praliases smrsh makemap vacation editmap
- do
- make DESTDIR="${D}" LIBDIR="${MY_LIBDIR}" MANROOT=/usr/share/man/man \
- SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root \
- MANOWN=root MANGRP=root INCOWN=root INCGRP=root \
- LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root \
- MSPQOWN=root CFOWN=root CFGRP=root \
- install -C "${MY_OBJDIR}/${dir}" \
- || die "install 1 failed"
- done
-
- for dir in rmail mail.local
- do
- make DESTDIR="${D}" LIBDIR="${MY_LIBDIR}" MANROOT=/usr/share/man/man \
- SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root \
- MANOWN=root MANGRP=root INCOWN=root INCGRP=root \
- LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root \
- MSPQOWN=root CFOWN=root CFGRP=root \
- force-install -C "${MY_OBJDIR}/${dir}" \
- || die "install 2 failed"
- done
-
- fowners root:smmsp /usr/sbin/sendmail
- fperms 2555 /usr/sbin/sendmail
- fowners smmsp:smmsp /var/spool/clientmqueue
- fperms 770 /var/spool/clientmqueue
- fperms 700 /var/spool/mqueue
- dosym ../sbin/makemap /usr/bin/makemap
- dodoc FAQ KNOWNBUGS README RELEASE_NOTES doc/op/op.ps
-
- newdoc sendmail/README README.sendmail
- newdoc sendmail/SECURITY SECURITY
- newdoc sendmail/TUNING TUNING
- newdoc smrsh/README README.smrsh
-
- newdoc cf/README README.cf
- newdoc cf/cf/README README.install-cf
-
- cp -pPR cf/* "${ED}"/usr/share/sendmail-cf || die "copy failed"
-
- docinto contrib
- dodoc contrib/*
-
- insinto /etc/mail
-
- if use mbox; then
- newins "${FILESDIR}"/sendmail.mc-r1 sendmail.mc
- else
- newins "${FILESDIR}"/sendmail-procmail.mc sendmail.mc
- fi
-
- # See discussion on bug #730890
- m4 "${ED}"/usr/share/sendmail-cf/m4/cf.m4 \
- <(grep -v "${EPREFIX}"/usr/share/sendmail-cf/m4/cf.m4 "${ED}"/etc/mail/sendmail.mc) \
- > "${ED}"/etc/mail/sendmail.cf || die "cf.m4 failed"
-
- echo "include(\`/usr/share/sendmail-cf/m4/cf.m4')dnl" \
- > "${ED}"/etc/mail/submit.mc || die "echo failed"
-
- cat "${ED}"/usr/share/sendmail-cf/cf/submit.mc >> "${ED}"/etc/mail/submit.mc || die "submit.mc cat failed"
-
- echo "# local-host-names - include all aliases for your machine here" \
- > "${D}"/etc/mail/local-host-names || die "local-host-names echo failed"
-
- cat <<- EOF > "${ED}"/etc/mail/trusted-users
- # trusted-users - users that can send mail as others without a warning
- # apache, mailman, majordomo, uucp are good candidates
- EOF
-
- cat <<- EOF > "${ED}"/etc/mail/access
- # Check the /usr/share/doc/sendmail/README.cf file for a description
- # of the format of this file. (search for access_db in that file)
- # The /usr/share/doc/sendmail/README.cf is part of the sendmail-doc
- # package.
- #
-
- EOF
-
- cat <<- EOF > "${ED}"/etc/conf.d/sendmail
- # Config file for /etc/init.d/sendmail
- # add start-up options here
- SENDMAIL_OPTS="-bd -q30m -L sm-mta" # default daemon mode
- CLIENTMQUEUE_OPTS="-Ac -q30m -L sm-cm" # clientmqueue
- KILL_OPTS="" # add -9/-15/your favorite evil SIG level here
-
- EOF
-
- if use sasl; then
- dodir /etc/sasl2
- cat <<- EOF > "${ED}"/etc/sasl2/Sendmail.conf
- pwcheck_method: saslauthd
- mech_list: PLAIN LOGIN
-
- EOF
- fi
-
- doinitd "${FILESDIR}"/sendmail
- systemd_dounit "${FILESDIR}"/sendmail.service
- systemd_dounit "${FILESDIR}"/sm-client.service
-}