summaryrefslogtreecommitdiff
path: root/mate-base/mate-applets/mate-applets-1.26.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 15:52:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 15:52:10 +0100
commit145ac95c683ecda55a9b2cafc84dced2e9c29e03 (patch)
tree3a7aac2c145afe328a1c610a9ee6d7f5b9fd271d /mate-base/mate-applets/mate-applets-1.26.0.ebuild
parentbb17db5f98333b3c74b4194d1c1136144f693add (diff)
gentoo auto-resync : 24:10:2022 - 15:52:09
Diffstat (limited to 'mate-base/mate-applets/mate-applets-1.26.0.ebuild')
-rw-r--r--mate-base/mate-applets/mate-applets-1.26.0.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/mate-base/mate-applets/mate-applets-1.26.0.ebuild b/mate-base/mate-applets/mate-applets-1.26.0.ebuild
new file mode 100644
index 000000000000..9a6d65f8af07
--- /dev/null
+++ b/mate-base/mate-applets/mate-applets-1.26.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Applets for the MATE Desktop and Panel"
+LICENSE="CC-BY-SA-3.0 FDL-1.1+ GPL-2+ GPL-3+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +cpupower ipv6 netlink policykit +upower"
+
+REQUIRED_USE="policykit? ( cpupower )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ >=dev-libs/libxml2-2.5:2
+ >=gnome-base/libgtop-2.12.0:2=
+ >=gnome-extra/gucharmap-3.0:2.90
+ >=mate-base/mate-panel-1.25.2
+ >=net-wireless/wireless-tools-28_pre9:0
+ >=sys-apps/dbus-1.10.0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/gtksourceview:3.0
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ >=x11-libs/libwnck-3.0:3
+ x11-libs/pango
+ cpupower? (
+ sys-power/cpupower
+ policykit? ( >=sys-auth/polkit-0.97:0 )
+ )
+ netlink? (
+ dev-libs/libnl:3
+ )
+ upower? ( >=sys-power/upower-0.99.8 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ mate-base/caja
+ mate-base/mate-desktop
+ >=mate-base/mate-settings-daemon-1.6
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+
+ # configure.ac logic is a little hinky
+ # and ignores --enable flags for cpufreq
+ use cpupower || myconf="--disable-cpufreq"
+
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ $(use_with X x) \
+ $(use_with upower) \
+ $(use_with netlink nl) \
+ $(use_enable ipv6) \
+ $(use_enable policykit polkit) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check
+}
+
+src_install() {
+ mate_src_install
+
+ local APPLETS="accessx-status battstat charpick command cpufreq drivemount
+ geyes mateweather multiload netspeed stickynotes
+ timerapplet trashapplet"
+
+ for applet in ${APPLETS}; do
+ docinto ${applet}
+
+ for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
+ [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
+ done
+ done
+}