summaryrefslogtreecommitdiff
path: root/mate-base/mate-menus/mate-menus-1.24.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /mate-base/mate-menus/mate-menus-1.24.0-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'mate-base/mate-menus/mate-menus-1.24.0-r1.ebuild')
-rw-r--r--mate-base/mate-menus/mate-menus-1.24.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/mate-base/mate-menus/mate-menus-1.24.0-r1.ebuild b/mate-base/mate-menus/mate-menus-1.24.0-r1.ebuild
new file mode 100644
index 000000000000..e0a404983b34
--- /dev/null
+++ b/mate-base/mate-menus/mate-menus-1.24.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GNOME2_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
+LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+"
+SLOT="0"
+
+IUSE="debug +introspection"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
+ # usage checks.
+ mate_src_configure \
+ --enable-debug=$(usex debug yes minimum) \
+ $(use_enable introspection)
+}
+
+src_install() {
+ mate_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ newexe "${FILESDIR}/10-xdg-menu-mate-r1" "10-xdg-menu-mate"
+}