summaryrefslogtreecommitdiff
path: root/mate-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-27 02:00:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-27 02:00:01 +0000
commitead7697a01fd631b56240b2d58aedd98ba7f92d3 (patch)
treec73ecbedbb9db967a7dff614f5e8b79eacb79f5d /mate-base
parent403335d7014372971e9e9267493a808d08bab48e (diff)
gentoo auto-resync : 27:11:2024 - 02:00:00
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/Manifest.gzbin2229 -> 2226 bytes
-rw-r--r--mate-base/mate-panel/Manifest2
-rw-r--r--mate-base/mate-panel/mate-panel-1.28.4.ebuild74
3 files changed, 76 insertions, 0 deletions
diff --git a/mate-base/Manifest.gz b/mate-base/Manifest.gz
index 88523bf16c0e..bd7f13fd8352 100644
--- a/mate-base/Manifest.gz
+++ b/mate-base/Manifest.gz
Binary files differ
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index 810da7ea1d2a..91317ec17ced 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1,3 +1,5 @@
DIST mate-panel-1.28.1.tar.xz 3282404 BLAKE2B 54a60c8fdf319ebe8678963faaeb6f93a1e60cb9ee43ed32896a04f1bdbcfc89d1b0696500948d334827d4d73d5373c748e53349c47559389ba2e4f51d31270a SHA512 50ecb7a3006e989c7e51ece72ef0f2ce0e1fec84844b97281e07f9f4b1005e3b81870d7bca882a453225e69db109a344e6fe80a12d2c4cdc54ef5d87fee68a7c
+DIST mate-panel-1.28.4.tar.xz 3240648 BLAKE2B 2db3962071eca43e29b4687988819de5777d753abea3b6087d3ff588c7db6f0305986943abebd700bdc3d0d6ddc6c8531debbbafdad92fad8ece48e8d906e1a9 SHA512 2a58c39c9b8b736e8c0e4623cdc7b84eaeb44bcd79299b18d20f69f4c06606ca07b502626c6502b5edf0586794977dba6757eb800ddc7e9bb532a5ec2a4b237a
EBUILD mate-panel-1.28.1.ebuild 1584 BLAKE2B 4e1054244ab0dae2f60a1362fe482aa3317e499467126c5bb6957b84414585cc728594471956ee1510e6a361f19f7e45d603282cd4da1cc19f4cb4b3cad5cf6a SHA512 e3d970be59bbf8ff263848664bee2438af9dc5ac66e69c935c2b0f0f0b346bbec08e48c4e803dd08d40bf9aab50970159cbfccfc268ab2da2ccdd98de7e5979f
+EBUILD mate-panel-1.28.4.ebuild 1586 BLAKE2B 25585f972574981ea1857a23dbc32be8765619436cb5ade581c88121dd587b24fcf9c100086511f73c2a233281dc93aa740f9ebe8d6893a5f3de40e4ceae9414 SHA512 61e1fb63877211a6da2964584467719d26366a43f48d1c099aba0fa7b766558b7590ec56e6c0013d9925b0c0b15bd1dc94d23a9265b98940c3e60604cc1ecad0
MISC metadata.xml 489 BLAKE2B e2e9add08fd20c16ff668fc0896ca5f5a5b9c3e165fb798535d791edbe2acbabd6081a97ffb6eba30af7d4ab12f313843012f5ad502b9415a63174d048b4b1e7 SHA512 7198638983e1f1942c4a156fd73520c745b24e5fb5eff85762ec5825892755b32fafee0d42e5b22a3c7381d14a36accebd0e8f0e8ffc61660ac5a17023edc1d8
diff --git a/mate-base/mate-panel/mate-panel-1.28.4.ebuild b/mate-base/mate-panel/mate-panel-1.28.4.ebuild
new file mode 100644
index 000000000000..82c9b5429129
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.28.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+X +introspection wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.28.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/dconf-editor-43.0
+ >=mate-base/mate-desktop-$(ver_cut 1-2)
+ >=mate-base/mate-menus-1.28.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1.0.0[X?]
+ >=x11-libs/gdk-pixbuf-2.26.0:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir="${EPREFIX}"/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}